Support » Plugin: Kaltura All-in-One Video Plugin for WordPress » [Plugin: All in One Video Pack] Can not add interactive video in wordpress

  • deniscao


    Hi guys,

    I got a problem here, and really need your help!

    Here is my situation:
    – REHL6
    – KalturaCE 1.5
    – WordPress 3.1.3
    – All in One Video Pack 2.4.3

    The KalturaCE works very well, and WordPress works well too, KalturaCE and WordPress are both installed on the same server, and WordPress url is: http://localhost/, url of KalturaCE is: http://localhost/KalturaCE.

    When I going to insert video into a post in WP, in ‘Add Interactive Video’ panel, I can only get a empty black box, when I right click on that area, I can see ‘Movie not loaded…’ context menu, and I see the url of the movie in source code: http://localhost/kalturaCE/kse/ui_conf_id/543.
    On the other hand, the panel ‘Browse Interactive Videos’ runs perfect.

    Any suggestion will be appreciate, thanks advanced.

Viewing 1 replies (of 1 total)
  • deniscao


    Fortunately, I made some progress here:

    in wp_content/plugins/all-in-one-video-pack/settings.php file, there’s a constant definition:
    define(“KALTURA_KCW_UICONF_ADMIN”, 543);
    this number is the parameter in the url http://localhost/kalturaCE/kse/ui_conf_id/543

    and then, I get into kalturaCE/kaltura/alpha/apps/kaltura/modules/extwidget/actions/kseAction.class.php file, figure out that the goal of the request is get url of a .swf file from DB, so I then browse table ui_conf in phpmyadmin, I didn’t find the record by id 543, instead I get id 533, it hold a configure file path, a swf file url, width, height, etc…

    Then I try change the parameter 543 to 533, the .swf file is loading this time, but it didn’t show anything; so I try again to create my own player in ‘Kaltura Management Console’ -> ‘Application Studio’, I make a new ‘Single Player’ by following the wizard, and finally got an ID 48412, I modified the parameter 533 to 48412, now I got an error in the flash player:

    Error in multiRequest :
    KalturaStartWidgetSessionResponseError #1034

    BTW, ui_conf with id 533 pointing to /flash/kdp/v2.0.12/kdp.swf, and my new one 48412 pointing to /flash/kdp/v2.5.2.30923/kdp.swf, both of them exist on the server.

    Is this a problem of the .swf player versions? Does it work on your web site?

    I posted this on Kaltura web site too:

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: All in One Video Pack] Can not add interactive video in wordpress’ is closed to new replies.