WordPress.org

Forums

All in One SEO Pack
[resolved] How to hide SEO Title | SEO Keywords | SEO Description (17 posts)

  1. Alkorr
    Member
    Posted 4 years ago #

    I'm using All in One SEO Pack Version 1.6.13 with WP 3.0.2 and since I upgraded, three new columns appear in the Post List in the Admin:

    SEO Title | SEO Keywords | SEO Description

    I don't want these columns to appear, they are messing with the titles on my posts in the list... I checked the plugin configuration page but I couldn't find anything.

    Thanks for your help!

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. wmmead
    Member
    Posted 4 years ago #

    Hi there is another post in this thread with the answer. While we wait for the developer to add the functionality to hide this stuff, we have to comment out the section of the code that displays this in the admin interface. I tried it and it is working for me.

  3. Alkorr
    Member
    Posted 4 years ago #

    Hi wmmead. Thanks for the tip but I don't want to edit core files... I did it once and I messed up. If it's the only solution maybe I will but I hope the developers of the plugin will find a solution soon because it's really messing with the Posts List and there is no option to hide the SEO columns...

    Wait and see.

  4. techgodown
    Member
    Posted 4 years ago #

    Hi,
    Its nothing to do with the Plugin configuration rather there is a simple solution to the problem.
    On the Top-right corner of the post list page there is "Screen options" tab below the log out link. Click on it and uncheck the SEO Title | SEO Keywords | SEO Description or whatever is undesirable.

    All the Best.

  5. hojjer
    Member
    Posted 4 years ago #

    Had same issue. Thanks techgodown for easy fix!

  6. Alkorr
    Member
    Posted 4 years ago #

    Hi techgodown, thanks but I tried that and it doesn't work! I unchecked the SEO lists and clicked on Apply but they still appear. I tried on my 2 WordPress installs and it didn't work on both...

    I'm stuck again, I'm afraid... :(

  7. Alkorr
    Member
    Posted 4 years ago #

    I read my message again and maybe I wasn't clear enough. I can hide the SEO stuff BUT the columns are just emptied, they still appear and it's messing with the overall presentation, my titles are now on 4 or 5 lines and it's really a mess.

    So I would like to know how to definitely get rid of the SEO columns.

    Thanks for your help!

  8. EivindFS
    Member
    Posted 4 years ago #

    Yeah, this has been doing my head in too - it ruins the posts display. Strange decision to turn it on by default.

    About techgodown's solution. That's great, though it only works for the user which you are currently logged in with. So if you apply that fix thinking it will apply to all users of the system, you are mistaken.

    Seems like the best bet is to wait for an update. Let's hope they wise up and create an option to remove it. I see no use for them.

    Eivind

  9. Alkorr
    Member
    Posted 4 years ago #

    Hi Eivind, good to see I'm not the only one bothered by these columns...

    Me too I'm waiting for an update but I'm not sure they know how bothering those 3 columns are! Do they even read this forum?

    This plugin is amazing but they must find a solution for this issue we have!

  10. Jevuska
    Member
    Posted 4 years ago #

    Same issue though

  11. Alkorr
    Member
    Posted 4 years ago #

    Hi jevuska! I wonder if there is a way to contact the developers of the plugin, just in case they don't read this forum and are not aware of this issue. Because we didn't get any comment from them yet, that's why I'm wondering if they even know about it...

  12. CharlesAmith
    Member
    Posted 4 years ago #

    In the main plugin file, you can find this:

    function aioseop_mrt_pcolumns($aioseopc) {
    $aioseopc['seotitle'] = __('SEO Title');
    $aioseopc['seokeywords'] = __('SEO Keywords');
    $aioseopc['seodesc'] = __('SEO Description');
    return $aioseopc;
    }

    If you remove these 3 lines and save, those columns won't show:

    $aioseopc['seotitle'] = __('SEO Title');
    $aioseopc['seokeywords'] = __('SEO Keywords');
    $aioseopc['seodesc'] = __('SEO Description');

  13. Alkorr
    Member
    Posted 4 years ago #

    Hi CharlesAmith! Thank you, that's a great solution, I'm gonna try it.

    But like I said earlier, it's not a lasting solution since I will have to do it for the next upgrade... I wish the plugin's developers would read this thread and do something (i.e add an option in the plugin config) so we could get rid of these columns.

    Thanks for your help, now we have to wait for the developers' will and time to work this bug out ;)

  14. Alkorr
    Member
    Posted 4 years ago #

    Still no solution? :(

  15. biralucena
    Member
    Posted 4 years ago #

    I don't know how new this feature is, but it is just a matter of unchecking post & page in the "Custom Post Types for SEO Column Support" field on the AIOSE settings page.

  16. Alkorr
    Member
    Posted 4 years ago #

    Hi biralucena! Thanks for the tip, it works great although I can only 'unselect' either 'Post' or 'Page' but not both of them.

    Let's say it's better than nothing, thanks you all for your help! :)

  17. biralucena
    Member
    Posted 4 years ago #

    Hi Alkorr,

    On OS X You can unselect everything by pressing the command key and clicking the last selected option. I don't know how to do it on Windows, but I know it's possible (try the control key).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • All in One SEO Pack
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic