Support » Plugin: All-in-One Event Calendar » [Plugin: All-in-One Event Calendar] Short code / filter by tag not working

  • Resolved Manu-PB



    I do not succeed in using the tag short code [ai&ec tag_id=”xx”] nor the filter link /../events&ai&ec_tag_ids=xx. The events are not filtered at all.
    This works fine for the categories, but not for the tags.

    Is it a known issue of the version 1.5? (I am still using the version 1.5, because I have made substantial modifications and I would not like to go into hard work for each new version.)

    Is there a way to have it running ?
    Thanks for help.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Richard


    Hi Manu-PB:

    The shortcodes should be written with ai1ec not ai&ec. For a full list of shortcodes, see here:

    If you are using the correct shortcode, and it is still not working for you, please email your WP admin access info to and we will take a closer look. Please be sure to include the post from above, so we have the context. Please also include the tag ID you are trying to use.

    Thanks for your message, Richard,

    1 – Of course it was ai1ec (just a type mistake).

    2 – The fact was, that I have hacked the calendar.php file to delete the “filter by tag” dropdown menu. I confirm that the short code operates in a post when putting it back 🙂

    3 – However, I have still some issues with it (see for instance this page)

    a/ since I do not want the user to see all tags, I have replaced all displays with `<?php echo ‘ ‘ ?>. But I was not able to delete the loop nor all the <input> lines (see the source code of the page). Is there a way to just “force” the display for a selected cat_name and not go through the loop?

    b/ the shortcode calendar is sorted by months : the “upcoming” and “previous” buttons refer to “paginated by month” views. Is there a way to show all upcoming (resp. previous) events like in the regular calendar view?

    c/ since I include the shortcode in a page, I would like to “skip” the headings of the agenda : month, valendar and filter buttons. Is there a way to do this only for the shortcode view?

    d/ the shortcode view is displayed AFTER the articles add-ons (like + related). This is probably linked to the theme, but is there a way to move it up, just after the text of the post?

    Many thanks for help!



    Hi Manu-PB,

    a. I will have to escalate this particular question to our Technical Support Specialist.

    b. You can display all upcoming events by using a shortcode like [ai1ec view=”agenda”] The number of events listed can be increased from your Calendar Settings page in the WP dashboard. Or when you say “regular calendar view” do you mean “Month” view? In which case, all upcoming events should automatically be in the month view, but of course you have to click forwards to the events in the next months.

    c. You can remove these headings by editing the code, but to my knowledge, this will remove the buttons for all ai1ec calendars on your site. However, I will double-check this with the Technical Support Specialist.

    d. This is known bug. Unfortunately, it is low on the list of priorities, so it won’t be fixed in the next upcoming release, however it will hopefully be fixed by the end of the year.

    Hi Richard,
    Thanks for your answer,
    Here are my comments :
    a/ waiting for a feed back from your specialists
    b/ are the [ai1ec view=”agenda”] and [ai1ec tag_name=”Halloween”] compatible, such as [ai1ec view=”agenda” tag_name=”Halloween”]? I’m talking about the “agenda” – and not “month” view.
    c/ maybe I can hack the code, testing if there is a tag_name request to skip the headings. But since I cannot escape the loop, I am afraid it will not be easy.
    d/ If if can be done in a short term, I would be very happy !
    Unfortunately I have no time this week to make tests : I will do next week and keep you updated.

    Hello I have the same problem

    I try put the shortcode on my category.php templtate like this

    <?php echo do_shortcode("[ai1ec cat_name=\"".$catname."\"]"); ?>

    But, It’s seems doesn’t work. Any idea?



    @benetj – the do_shortcode function does not work with ai1ec shortcodes, however it is on our list to add this in the future. In the meantime, here is a list of the available shortcodes:

    @manu-pb – regarding shortcodes – YES – using two shortcodes at once works, including for agenda view. So for example this should work:
    [ai1ec cat_name=”Your Category” ai1ec view=”agenda”]

    I have tried this at my end and can confirm it words.

    thanks Richard 🙂



    You’re Welcome!


    When did shortcodes no longer work? do_shortcode used to work, then I upgraded to standard or what ever for free which was a nightmare as I had to find a thread and download v1.8 because the one the default version upgrades to breaks wordpress. Finally got it working again and now the do_shortocode doesn’t work. So it works in the basic basic but not the basic standard?

    Yes, Im having the same problem with the shortcode…

    No matter what i do i can’t make any short codes work in ai1ec v1.1-standard with WordPress v3.5.1

    For instance
    [ai1ec view=”weekly”]
    just shows the default monthly calendar.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] Short code / filter by tag not working’ is closed to new replies.