WordPress.org

Support

Support » Plugins and Hacks » All-in-One Event Calendar » [Resolved] [Plugin: All-in-One Event Calendar] partly missing german translation

[Resolved] [Plugin: All-in-One Event Calendar] partly missing german translation

Viewing 8 replies - 1 through 8 (of 8 total)
  • Richard

    @richardgirling

    Hi k___k,

    You can alter this depending on what view you wish to change in the calendar.css file.

    And where I can find that file?

    Richard

    @richardgirling

    wp-content/themes-ai1ec/vortex/style.css

    I hope this helps!

    McCavity

    @mccavity

    Hi,

    sorry to tailgate this thread, but I have a few minor problems with the german translation as well. I was able to correct a few glitches in the .po and .mo files myself, however, some of the translations won’t show up (or don’t exist). I can live with that in the backend, however, in the frontend it may confuse users. I have prepared a screenshot at http://www.diigo.com/item/image/3d6d4/07xp which shows the three problems in the frontend:

    • The view selector
    • The “Post Your Event Button” (not a real problem, that’s for contributors only, they can deal with that)
    • The “View Claendar” Button

    Link to see the page in action: http://eckradio.de/ppbv/termine/
    And yes, the translations are in the .po and .mo files. Any hints how I can solve that?

    Thanks a lot in advance & kind regards

    Henning Halfpap

    Richard

    @richardgirling

    Hi Henning,

    Thank you for your input here. Our translations are provided by volunteers from around the world. If you have updated translation files, please feel free to share them with us by emailing them to translations@time.ly and we will try to incorporate them in a future release.

    In the mean time, the file for changing the translations in the view selector is: all-in-one-event-calendar/app/model/class-ai1ec-settings.php (lines 423-427).

    Some further guidance here: http://help.time.ly/customer/portal/articles/602306-how-can-i-change-edit-or-translate-the-language-

    If you require any further assistance, please feel free to email us direct at help@time.ly

    Thank you.

    McCavity

    @mccavity

    Hi, Richard,

    thanks for the tips, I’ll have a look into it as soon as I can. If I find a solution, I’ll drop you a line.

    Thanks again & kind regards,

    Henning

    McCavity

    @mccavity

    Hi, Richard,

    short follow-up: thanks for the tip on all-in-one-event-calendar/app/model/class-ai1ec-settings.php (lines 423-427). I modified the lines as follows;

    'posterboard' => __( 'Pinwand', AI1EC_PLUGIN_NAME ),
    'month' => __( 'Monat', AI1EC_PLUGIN_NAME ),
    'week' => __( 'Woche', AI1EC_PLUGIN_NAME ),
    'oneday' => __( 'Tag', AI1EC_PLUGIN_NAME ),
    'agenda' => __( 'Agenda', AI1EC_PLUGIN_NAME ),

    So anyone with the same problem: just change the strings in those lines to your language and you’re good to go.

    I also found the problem with the “View Calendar” button in the widget: in the german .po file the key was botched: I compared the entry to the .pot file and found there were some extra characters in the string which prohibited the match. After removing the extra characters from the key (and generating the .mo file again) the string is now recognized and I see the german caption.

    I’ll leave the backend alone for now, that is of no importance to me. I’ve sent the updated .po and .mo files to translations@time.ly – maybe you can use them.

    Thanks again for your support,

    Henning

    Richard

    @richardgirling

    Great, thanks so much for catching this and emailing the updated file. We’ll be aiming to include this in a future release.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: All-in-One Event Calendar] partly missing german translation’ is closed to new replies.
Skip to toolbar