Support » Plugin: All-in-One Event Calendar » [Plugin: All-in-One Event Calendar] Lots of errors ….

  • Simply put, set WP_DEBUG to true in your config.php file and then use the plugin. There’s a BUNCH of NOTICE level errors from unchecked variables/constants, making it impossible to develop themes/other plugins with WP_DEBUG turned on and this plugin enabled.

    Since I need to use this plugin, I’ll gladly fix them and submit the corrections to you if you would like.

    Thanks.

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Also, in class-ai1ec-calendar-controller.php on line 454, l10n needs to be added as a dependency for calendar.js because I was getting the error about convertEntities is not defined, which as of at least 3.1, it gets defined in the l10n.js built into WordPress.

    When I checked, it wasn’t loading before your javascript, so it needs to be added as a dependency to ensure it is loaded in time.
    I’m not yet sure why, but the buttons to switch between Month and Agenda views don’t do anything and it’s not triggering any sort of JS errors. I haven’t looked to see if anyone else is having this issue, but it’s definitely not working on my 3.3 install. Thanks!

    Plugin Contributor Yani Iliev

    (@yaniiliev)

    @amereservant
    I can confirm that the notices are fixed. We will have a new version released soon.
    The plugin behaves well on 3.3
    I am wondering if you are using a custom/non-default theme?
    Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] Lots of errors ….’ is closed to new replies.