Support » Plugins and Hacks » All-in-One Event Calendar » [Plugin: All-in-One Event Calendar] Import and ICS feed don't work

  • Resolved ldopierala

    (@ldopierala)


    Hello,

    I try to use All-in-One Event Calendar to import automaticly some Event from ICS File, or Google Apps, but it don’t works..
    I can’t found any information about this. I can add my ics feed from Google Calendar but no import.
    Anyone have an idea to import autmaticly Event to All-in-One Event Calendar ?

    Thanks for help and Happy New Year

    Ludo

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

Viewing 15 replies - 16 through 30 (of 45 total)
  • bradycreative

    (@bradycreative)


    I tried eliminating just the s in the https but it seems to still not show up on the front end. would another plugin be messing it up?

    Plugin Contributor Yani Iliev

    (@yaniiliev)


    @bradycreative
    When you add the ics file and hit the Update button, do you see a “Flush 1 event” button showing up after the request is complete?
    Also, does the event show up in all events list?

    bradycreative

    (@bradycreative)


    I deactivated all plugins and still nothing. the prompt I receive is “No events were found” when I click to update the ics feed.

    Plugin Contributor Yani Iliev

    (@yaniiliev)


    Can you upload a test.php file with the following code and paste the output:

    <?php
    print_r(stream_get_wrappers());
    ?>

    bradycreative

    (@bradycreative)


    Array ( [0] => https [1] => ftps [2] => compress.zlib [3] => compress.bzip2 [4] => php [5] => file [6] => data [7] => http [8] => ftp [9] => zip )

    Plugin Contributor Yani Iliev

    (@yaniiliev)


    Okay, that means your server is able to get the ics feed. Now, the problem must be somewhere else.
    Can you make me a temporary user with super user rights?
    My email address is: yani at the-seed dot ca

    bradycreative

    (@bradycreative)


    Thank you for your help!

    Plugin Contributor Yani Iliev

    (@yaniiliev)


    No problem.
    Can you upload a test.php file with the following content and paste the output:

    <?php
    error_reporting(E_ALL); ini_set('display_errors','On');
    echo file_get_contents( 'http://www.google.com/calendar/ical/161hkrdo0qrhfc6sj4s613gib4%40group.calendar.google.com/public/basic.ics' );

    bradycreative

    (@bradycreative)


    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /homepages/2/d175715330/htdocs/ECBC/test.php on line 3

    Warning: file_get_contents(http://www.google.com/calendar/ical/161hkrdo0qrhfc6sj4s613gib4%40group.calendar.google.com/public/basic.ics) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /homepages/2/d175715330/htdocs/ECBC/test.php on line 3

    Plugin Contributor Yani Iliev

    (@yaniiliev)


    @bradycreative
    You will have to get in touch with your hosting provider and tell them that you need to use php file_get_contents function.
    If the need an example, you can use the code below:

    <?php
    error_reporting(E_ALL); ini_set('display_errors','On');
    echo file_get_contents( 'http://www.google.com/calendar/ical/161hkrdo0qrhfc6sj4s613gib4%40group.calendar.google.com/public/basic.ics' );

    One that has been taken care of, try importing the feed again and let me know if you are still having troubles 🙂

    bradycreative

    (@bradycreative)


    They said the php file_get_contents function is working but to enable it I need to make a php.ini file, put in this syntax: allow_url_fopen = On

    but it still doesn’t seem to work :/

    Plugin Contributor Yani Iliev

    (@yaniiliev)


    @bradycreative

    Make sure that the php.ini file is placed here: /homepages/2/d175715330/htdocs/
    If you have access, put another copy of php.ini here: /homepages/2/d175715330/

    Also, try adding the following line to your .htaccess file (/homepages/2/d175715330/htdocs/.htaccess):
    php_flag allow_url_fopen On

    When you are done with the changes, the first thing to try is to access a test.php file with the following content:

    <?php
    error_reporting(E_ALL); ini_set('display_errors','On');
    echo file_get_contents( 'http://www.google.com/calendar/ical/161hkrdo0qrhfc6sj4s613gib4%40group.calendar.google.com/public/basic.ics' );

    If you see the following output:

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /homepages/2/d175715330/htdocs/ECBC/test.php on line 3

    then you should try contacting again your hosting provider and ask them to do the change for you.
    Otherwise, if everything is correct, try importing the ics feed again.

    bradycreative

    (@bradycreative)


    It seems to be working now. Thanks.

    Thanks for this support thread, fixed any issue I had. This plugin is wonderful.

    HI there,

    I am having a similar problem and I followed all the steps in this thread. I activated the php.ini allow_url_fopen = On. I didn’t do the .htaccess because it give me a 500 error and I read these only work in php 6 anyhow.

    I am hosted on 1and1.com.

    I also tested the :

    <?php
    error_reporting(E_ALL); ini_set('display_errors','On');
    echo file_get_contents( 'http://www.google.com/calendar/ical/161hkrdo0qrhfc6sj4s613gib4%40group.calendar.google.com/public/basic.ics' );
    
    ?>

    You can see the result here :
    http://radhayogacenter.org/wordpress/test.php

    Which display the actual calendar. I looked into the error trough the firebug ajax-admin script and it cleanly give an error that there is no event.

    I tried the calendar on a different site and it worked so it’s defenitly my settings or my host :S.

    The calendar I am working with is :

    https://www.google.com/calendar/ical/p2cair4pvme86jk5jk8hiidufk%40group.calendar.google.com/private-e7c7f3286e569f11085df6510f1c54ec/basic.ics

    which is also copied locally to test here :

    http://radha.org/basic.ics

    The php info shows that I have these on :

    allow_url_fopen On On
    allow_url_include On On

    http://radhayogacenter.org/wordpress/phpinfo.php

    What else should I be looking for ?

Viewing 15 replies - 16 through 30 (of 45 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] Import and ICS feed don't work’ is closed to new replies.