Support » Plugin: All-in-One Event Calendar » [Plugin: All-in-One Event Calendar] ICS feed "No events were found"

  • Resolved Al



    I’m having trouble getting a remote ical to load into this plugin. I had been using an older version just fine, but now the calendar is blank. It appears that the plugin has been upgraded by someone else via wp-admin and this somehow broke things.

    I have tried removing the plugin and reinstalling but with no luck (that includes manually removing files after running uninstall).

    When I try to load an ics with the WordPress admin interface, the plugin returns “No events were found”. I validated the ics with an external validator and it came back fine. I have loaded the ics into iCal on my Mac and thats fine.

    I found a suggestion that the server may have PHP limits that restricted the plugin from getting the ics, so I tested that with

    error_reporting(E_ALL); ini_set('display_errors','On');
    echo file_get_contents( '' );

    and that comes back fine with no errors.

    I’m at a loss as to how to debug further. Any suggestions would be welcomed.

    Plugin version: 1.8.3
    WordPress version: 3.1.1 and 3.1.2 tried
    PHP version: PHP 5.3.3 (via Centos 5.8)

    Thanks in advance,

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your code may now have been permanently damaged/corrupted by the forum’s parser.]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Richard


    Hi Al,

    I tried importing your feed into my ai1ec and I was able to import 226 events. So for some reason, the feed works with my settings, but not for yours.

    In order to rule as many things out as possible, are you able to upgrade to the latest version of WordPress (or at least 3.4.1) and let me know if you still cannot import the feed?



    Hi Richard,

    Apologies. I am on WP 3.4.2. Why my brain thought 3.1.4 when I originally posted I know not. I know the feed/plugin worked on 3.4.1, then didn’t and I then upgraded to 3.4.2. The plugin was originally installed about 4 months ago and has been updated via wp-admin at various points inbetween.

    I also now have the feed working on a copy of the same WordPress install, but on a different server (rsync’d htdocs and mysql-dump of the databases copied across). On that server I uninstalled from wp-admin, deleted the remaining files in wp-content and then reinstalled. That then worked fine. When I try that on the live WordPress it does not work and still says “No events were found”. Settings for ai1ec are the same between the two installs.

    The PHP configs are pretty similar, scanning the differences I can’t see anything that would make any real difference (error reporting levels mainly).

    It does feel then that there is a setting somewhere, perhaps in the DB, that isn’t the same once copied and uninstalled. Not sure where to look for that though.




    Hi Alastair,

    Thanks for all this information. I agree that there must be a difference between your two installations which is causing one to work, and one to fail. We had one user who said that he had the same issue and the only difference was the DNS (one was GoDaddy and one was a different one. The GoDaddy one worked, but the other one did not…)

    Let’s rule that out, then go from there…



    I can’t see DNS being the issue. I can call the ics from a PHP script directly without issue and grab it from cmd line with curl, again with no issue.

    I also placed the ics file on the local server in the root directly of the website, and tried importing it from there, so using the local host rather than, but that gives the same error of “No events found”.

    It is as if the parser simply isn’t parsing the ics file correctly.



    Hi Al,

    Can you please send me a copy of the ics feed? We have had some issues with some feeds having a ‘blank’ top line. If you wish to send it to us then we can check this for you. Please put [Richard] in the title and also copy the url of this feed into the description box. Thanks



    Hi Al,

    I am going to mark this thread as resolved as we have not had a reply for over a month.





    This actually remains unresolved on our site. You did have the feed URL via email, where there had been some toing and froing with suggestions to try this and that, but nothing that works.

    I’ll follow up again with you via your email.


    I have the same problem. Events from the .ics file are shown locally and on my ipage hosted site, but not on my media temple hosted site. I tried all of the above as well. Any help would be appreciated!!

    Likewise. I am able to read my google Calendar feed in other programs/plugins, and can use the iFrame html link google provides for the calendar just fine, but when I use it in All-In-One-Event-Calendar it returns ‘No events were found.’ This is so frustrating as Timely’s plugin otherwise seems amazing, but is useless without this functionality. Any suggestions as to how to resolve it would be greatly appreciated!



    Same problem, with Google Calendar feed. Does anyone have a solution?

    Plugin Contributor nicola.peluchetti


    Hi, probably there is an error somewhere. post your question. Can you post questions on our forums?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] ICS feed "No events were found"’ is closed to new replies.