Support » Plugin: All-in-One Event Calendar » [Plugin: All-in-One Event Calendar] Ical imports not working

  • In reference to my post “I am having difficulty importin an ics feed from google calendar. It is a private feed and works OK to outlook but clicking update on the iCalendar/.ics Feed URL: results in an alert box saying no events found.” I have located the source of the problem.

    Google calendars gives the URL as https
    I replaced the https with http and it works. Hope this helps other users as I have noticed a lot of similar posts where the import does not work.

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

Viewing 7 replies - 1 through 7 (of 7 total)
  • The iCal ics feed option is broken. Period. End of story. I’ve been doing a little more research on it with my ISP. I now have a test file that shows very clearly that it’s not my hosting company.

    jodywhitesides.com/testcal.php

    Quite clearly my iCloud/iCal public feed shows events. However no matter what I do with All In One, I can not get it to show the feed in the plug in. I get a message that pops up every time saying there are no events in the feed – which is quite clearly false.

    The plug in is broken in terms of ics feeds that come from iCloud.

    Additionally, I have deleted all other plugins. I’ve tried reinstalling wordpress. I even deleted and reinstalled Firefox and tested this in several browsers. All to no avail.

    I then thought maybe it was something in the iCal events themselves so I deleted the locations and notes for each event. Still will not show in All-In-One.

    v1.5 is simply broken for being able to import ics feeds from iCloud.

    I’m looking specifically for a calendar plugin capable of importing iCal and have been testing All-In-One Event Calendar for the past week. I must concur that it is not working, and this is very frustrating. I’ve tried several different calendar feeds through box.net and google. I’ve verified that the feeds have valid events. I’ve been able to successfully import the feeds into iCal. But when I try to import the feeds into the plugin, it tells me there are 0 events found.

    I’m hoping the developers shed some light on this problem soon.

    I too have tried to no avail to get this fixed. I have tried everything from this thread http://wordpress.org/support/topic/plugin-all-in-one-event-calendar-import-and-ics-feed-dont-work?replies=32 and can only conclude that version 1.5 is well and truly broken for iCal feeds.

    Has anyone had any joy getting a response from the developer?

    WordPress version: 3.3.2
    All-in-one Event Calender version: 1.5

    If no events are found, it can be a sign that:
    * the ICS feed is not a correct URL
    * the feed has no events in the future
    * the feed is private (when exporting from google calendar for example, be careful of privacy settings)
    * There is a PHP related error: Timeout, Disabled Functions, etc.

    For the feed-related issues, please paste the URL to the feed you are testing, and we can see if there is an obvious reason no events are found, but please do try and check for the items above.

    If the feed is fine, it can be a sign of a PHP related error.

    If your feed has many entries, this could cause a timeout. Please try testing an import of a feed with only 1 or a few events.

    If it isn’t a timeout, please follow some of the tips which doodlewhale linked to in this thread:
    http://wordpress.org/support/topic/plugin-all-in-one-event-calendar-import-and-ics-feed-dont-work?replies=32

    Namely checking a basic PHP import with a test.php file from the suggestion:

    Can you upload a test.php file with the following content and paste the output:

    <?php
    error_reporting(E_ALL); ini_set('display_errors','On');
    echo file_get_contents( 'http://www.google.com/calendar/ical/161hkrdo0qrhfc6sj4s613gib4%40group.calendar.google.com/public/basic.ics' );

    If you see the following output:

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /homepages/2/d175715330/htdocs/ECBC/test.php on line 3

    Then you should try contacting again your hosting provider and ask them to enable this ability.

    We are working to add some more debug output for ICS imports to catch the different ways it can fail.

    @jwhitesides – the feed URL you posted works for me with 1.5. This means the feed is fine, and 1.5 can import from icloud. Please check for PHP issues as per above.

    Thanks!

    @neira I just edited this post after writing a long explanation of what was ignored. Then I decided to go try one thing that was the exact opposite of the original poster of this thread…

    Feeds coming from iCloud when you copy the URL starts with webcal:// Putting that into All-In-One used to work and All-In-One would change it to http. For some reason, using http fails to work from iCloud.

    One a whim, after reading your post @neira, telling me what I already knew – that the feed is valid. I decided to try replacing webcal:// with https:// before hitting subscribe. Low and behold, it worked. It read the feed and imported all the events in.

    The problem is: It’s still getting the times incorrect and is not showing all day events on the correct day(s) [in looking at old events]. It’s off by an hour on events giving specific times.

    Now comes the concept of wondering why it’s not reading the correct time zone information and why all day events show up on the day before they happen and why a multi day event only shows on the first day and not all of them.

    Not out of the woods yet, but taking a step closer to full working ability.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] Ical imports not working’ is closed to new replies.