Support » Plugins and Hacks » All-in-One Event Calendar » [Resolved] [Plugin: All-in-One Event Calendar] Google Map not displaying

[Resolved] [Plugin: All-in-One Event Calendar] Google Map not displaying

Viewing 15 replies - 1 through 15 (of 27 total)
  • To disable the google maps function go to the plugins folder and to the folder for the all-in-one plugin, then apps, then view and edit the event-map.php file.

    You can simply delete the content or comment it out. OR even better add the code you see below that allows you to add your own google map “embed” code (from maps.google.com) as a custom field called google_map. Be sure to enter the Venue name and Address to make the system display the “custom map”

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    Thanks for the workaround, but I would really like to get this working and show the map. Can you confirm that this is a problem for you also?


    This is a strange bug – if you could send your login information to help@theseednetwork.com we can take a look at it for you.


    Hey guys,

    I’m having the same issue (at least the same symptoms). My problem is definitely due to one of the changes I’ve made to the theme I’m working on. I set my theme back to twenty ten and it works perfectly. Alley, if you haven’t tried that, test it out to see if it’s something in your theme (as opposed to an actual error in the plugin).


    Just as a follow-up I’ve identified the version of nicEdit that I’m running for my forums is conflicting with the plugin.

    thanks FraserMedhurst, I tried twentyeleven theme and the plugin behaves as expected. However, this is not an option for the website as it is a customised Atahualpa theme setup. I was wondering if this were a theme issue or a plugin issue?

    i have the same problem, google map display on twentyeleven but not on my personal theme… anyone solved this ?

    Hi frank4 – what’s your url -we have received a few reports of this, but it’s not widespread – the more data points we have the better.

    @alleyoopster – it’s obviously a conflict with the theme and the plugin. We do our best to have no conflicts, but we can’t test everything.

    can you also supply your url?

    i found the conflict : i had a function called in a personal js :

    	function externalLinks() {
    		if (!document.getElementsByTagName) return;
    		var anchors = document.getElementsByTagName("a");
    		for (var i=0; i<anchors.length; i++) {
    			var anchor = anchors[i];
    			if (anchor.getAttribute("href") && anchor.getAttribute("rel") == "external") {
    				anchor.target = "_blank";
    	window.onload = externalLinks;

    The “window.onload” makes the conflict.
    So i left this function aside, but would appreciate another way to generate a target=”_blank”

    thanks for the self help and the url – a ticket has been created to investigate this.

    Hi; I would appreciate help with this also, please. The URL is soi-seattle.org

    The Google maps feature worked fine on our developer’s site, but when we transferred the site files to DreamHost and went live, the events pages show a blank box on the right and a ‘view full-size map’ prompt.

    Will someone please help with this?

    Thank you!

    Hi there. I am having the same issue. the map wont display in the event.

    Here is the link to the page


    Hi. This issue is now resolved as a result of this clue from the theme author in response to our other problem (“Drop-down menus not showing in IE9”.) It wasn’t the plug-ins causing the problem. We accessed the ‘console’ entry via ftp, about 5 levels deep and deleted it, then the maps worked fine. If you can’t locate it, please write back and I will ask my partner to tell the pathway we took. Best Wishes.
    ‘some JavaScript functionality is adding logs to the JavaScript console and I think when the console is disabled, this stops executing some scripts. When you enable the console (F12 enables the developer tools), everything works normally. As I always have the console enabled by default, I didn’t experience any problems.
    So, this is most likely caused by a plugin installed, so you can try with temporarily disabling all the plugins installed. Or if you have added some additional JavaScript code, just make sure to delete the logging lines:

    console.log(…); ‘

    thanks surachar – this should be fixed in 1.8 as we are completely refactoring our javascript

    Glad; thanks for writing back. For anyone else, here are the pathway and instructions:

    The file that needs to be edited is the “script.js” file in this directory:

    “soi” is a variable in the path, so other wordpress installations will have a different value in the path there. Think of it really as /wp-content/themes/FOO/script/. The soi directory is probably a modification of dandelion, as the “dandelion” directory does not reference console.log in it’s script.js file. Consequently I’m not sure how useful this fix will be to other users of the dandelion theme.

    if in doubt, you can turn on script debugging in internet explorer, and you’ll see an “object is undefined” type of error pointing to console.log on a particular line of the script.js file. You can see the path there while in debug mode.

    the line that needs to be commented out is
    // console.log(jQuery(this));

    Apparently “console” is only a valid object reference while Internet Explorer’s developer tools are active. This is why the menus work when you’ve activated developer tools by pressing F12.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] [Plugin: All-in-One Event Calendar] Google Map not displaying’ is closed to new replies.
Skip to toolbar