WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: All-in-One Event Calendar] Google Calendar Feeds Not Showing?

[Resolved] [Plugin: All-in-One Event Calendar] Google Calendar Feeds Not Showing?

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Contributor Yani Iliev

    @yaniiliev

    When you add the feed to your settings page, you have to click on the update button.
    I tried it myself and it imports 10 events.

    I’m trying to import a Google calendar but having the same problem. I press ‘update’ in Settings after adding the iCal address and the circular indicator constantly shows itself as busy. I’ve tried several times.

    I’m using Firefox. I’ll try it in Chrome shortly to see if it’s a browser issue.

    Plugin Contributor Yani Iliev

    @yaniiliev

    Could it be a firewall issue?

    I turned off the firewall and the same problem continued.

    I run five WordPress sites with loads of plug ins and none have encountered this issue before, so it has to be something related to this plug in.

    Plugin Contributor Yani Iliev

    @yaniiliev

    We can do the following:
    1. You can give me the ics feed and I can try it on my install.
    2. You can create a new WP install, enable ai1ec plugin and test importing of the feed.

    Try this. It’s been set to public and only has one event in so far:
    https://www.google.com/calendar/ical/d8v2ngcq4dc64oohsobfmejefo%40group.calendar.google.com/public/basic.ics

    Thanks for your prompt response, by the way: appreciated!

    Mike

    Unfortunately still no luck and I have tried all calendar feeds and of course hit “refresh” multiple times. I dont get any errors or any notice at all about successfully finding any events.

    Calendar remains empty

    http://www.squamishspeaks.ca/calendar-new/

    Plugin Contributor Yani Iliev

    @yaniiliev

    It must be something in your setup, either a plugin is interfering or something is blocking the request to retrieve the feed.
    I tried urban75 feed and it successfully imports 1 event.

    Can you setup a test user for me so I can locate the problem on your setup. I have to warn you that if it is not a bug in the plugin, you will have to use our premium support. This will allow me to fix the problem.

    Yani – can you post up your email address so I can sort you out a log in for the site?

    It does seem very odd – all the other plug-ins work fine across all my other WordPress installations – and this is a brand new installation with only the default plug ins installed.

    Plugin Contributor Yani Iliev

    @yaniiliev

    Sure,
    yani at the-seed.ca

    Log in details sent. My tech guy says that we’ve reinstalled WordPress, recreated the config file and restarted Apache but it seems to throw up in the same places every time.

    Plugin Contributor Yani Iliev

    @yaniiliev

    I haven’t received the login details yet.

    Here’s some of the errors we’re getting:

    [Thu Oct 13 10:27:30 2011] [error] [client 188.222.96.49] PHP Warning: file_get_contents(https://www.google.com/calendar/ica…fo@group.calendar.google.com/public/basic.ics) [function.file-get-contents]: failed to open stream: No such file or directory in /usr/home/www/vhosts/www.brixtonbuzz.com/wp-content/plugins/all-in-one-event-calendar/lib/iCalcreator.class.php on line 1558, referer: http://www.brixtonbuzz.com/wp-admin…event&page=all-in-one-event-calendar-settings

    *password sent again

    Plugin Contributor Yani Iliev

    @yaniiliev

    Ah great. I received the login credentials but after seeing this error I no longer need it.
    You can delete the test WP account.

    The error is due to incorrect server configuration.
    Basically, file_get_contents cannot retrieve the ics feed.
    My initial thought is still valid: possible firewall issue.

    You can either ask your tech guy to fix this issue or you can fill a support request here: http://theseednetwork.com/get-supported/software-support/

    Here’s what our tech guy thinks:

    Okay, I think I’ve tracked down the problem with the plugin.

    It assumes that PHP has been built with an fopen() wrapper to handle SSL and https, which in our case is not true and so every outbound request using file-get-contents to https destinations will fail. If the plugin were to try using cURL instead, it would work.

    So to make that part work we’ll need to recompile PHP for the whole server. This will mean taking all the sites down while the new version is installed.

    My response: – is this something that his plug in should be able to handle?

    Well, it’s making assumptions about the environment which aren’t going to be true of every installation, but then so would assuming cURL was installed.

    You could let him know that you think you’ve tracked down the problem:
    That it assumes that PHP has fopen wrappers compiled in for HTTPS, which isn’t the case on our install.

    It’ll help him a) troubleshoot others who have similar issues, b) specify the requirements for the plugin better and c) improve his error-handling.

    $w = stream_get_wrappers();
    echo ‘openssl: ‘, extension_loaded (‘openssl’) ? ‘yes’:’no’, “\n”;
    echo ‘https wrapper: ‘, in_array(‘https’, $w) ? ‘yes’:’no’, “\n”;

    will tell him whether the installation has the required wrappers.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] [Plugin: All-in-One Event Calendar] Google Calendar Feeds Not Showing?’ is closed to new replies.