Support » Plugin: All-in-One Event Calendar » [Plugin: All-in-One Event Calendar] Fatal error: Ai1ec_Settings::get_instance()

  • Hi, I just installed the All-in-One Event Calendar on a WP3.3 site. When adding an iCalendar/.ics Feed URL I got this error message.

    Fatal error: Ai1ec_Settings::get_instance() [ai1ec-settings.get-instance]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition “Ai1ec_Settings” of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /somedomain/wp-content/plugins/all-in-one-event-calendar/app/model/class-ai1ec-settings.php on line 242

    All help would be appreciated, I’ve no idea where to start. Tnx!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,

    What version of PHP please? I’m not familiar with this and will have to search a bit on it

    Hey, ty for your reply, Nelra.

    Is the php version the same thing as the WordPress version? It’s the latest WordPress install. Or where could I find this info?

    What I do not understand however is that the problem has solved itself. The calendar is accessible again and the .ics that I tried to add is there anyway. If the error would come again, I’ll post the error message again.



    I just found which php version it is and some more info,

    Operating Systeem : Linux (64 Bit)
    Server : Apache
    Geheugen gebruik : 53.13 MByte
    MYSQL Versie : 5.0.92-community
    SQL Mode : Niet ingesteld
    PHP Versie : 5.2.17
    PHP Safe Mode : Uit
    PHP toegestaan URL fopen : Uit
    PHP Geheugen Limiet : 256
    PHP Max Upload formaat : 20M
    PHP Max Post formaat : 20M
    PCRE Backtracking limiet : 500000
    PHP Max Script Uitvoering tijd : N/As
    PHP Exif ondersteuning : Ja ( V1.4 )
    PHP IPTC ondersteuning : Ja
    PHP XML ondersteuning : Ja

    I got the same error message again twice, but since I deactivated the W3 Total Cache plugin, the error didn’t appear again.

    However, the All-in-One Event Calendar is still not working. Currently when loading the Calendar page, the plugin keeps loading… It didn’t do that when W3 Total Cache was active.

    All tips are welcome here! TY!!



    I’m seeing the same error as of this morning, 2-3 days after activating W3 Total Cache.

    Plugin Contributor Yani Iliev


    There is an option to flush all caches in W3 Total Cache.
    Try flushing the cache and see if it makes any difference.

    I will be investigate what is causing the problem with W3 Total Cache and look if there is something that we can do to overcome that issue.



    TY Yani!

    I however can’t tell you if it would help. On the site I was talking about the Calendar page is offline. It’s not my decision, so I can’t change that.

    I plan to install both plugins on the next site I make, but this one will be on a different server until august… So, possibly I won’t run into the same problems until that time.

    Either way, if I do, I’ll report it in this forum… I’d like to see the best cache and the best calendar plugin get along 😎



    We are experiencing the same problem, but instead of W3 Total Cache, we are using memcached ( for persistent caching.

    We have gotten to work around this by:
    1) Deactivate plugin
    2) Remove all ai1* settings from wp_options table and delete any ai1* tables.
    3) Flush memcache
    4) Activate plugin
    5) Flush memcache
    6) Configure plugin
    7) Flush memcache

    So basically — flush caches before and after any changes.
    We’d love any help in figuring out why this is the happening. Thanks!

    Plugin Contributor Yani Iliev


    Thank you for your feedback!
    I will research memcache and see what might be causing the issue.

    w3 page minify was minifying the add_new_events.js. You need to add a ; after the regex string for this plugin to work correctly:

    var isUrl = function( s ) {
            var regexp = /(http|https|webcal):\/\/(\w+:{0,1}\w*@)?(\S+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?/;
            return regexp.test(s);

    without that ; after the regexvar it gets compressed to ?/r and that isn’t a valid regex string.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] Fatal error: Ai1ec_Settings::get_instance()’ is closed to new replies.