Support » Plugin: All-in-One Event Calendar » [Plugin: All-in-One Event Calendar] Event details not showing

  • Resolved manajoe

    (@manajoe)


    Hi there,
    I installed your plugin in version 1.2.4 and I’m thrilled, its exactly what I was looking for. Just this little problem:
    I add an event, which is displayed in all views (month, week, agenda), I can expand and collapse the view. But if I click on “Details”, I just get an almost blank page, with only the event title displayed, not the information and google maps.
    I can view the details, if I go to the event using this link: ?ai1ec_event=ah-training&instance_id= without an instance_id-number. As soon as there is a number following (which seems to be the default and necessary for repeated events) ?ai1ec_event=ah-training&instance_id=3 I just get this blank page. (testlink http://test.mm13.de/?ai1ec_event=ah-training&instance_id=3)
    Are there any hints for me?
    Greetings
    Mana

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

Viewing 15 replies - 1 through 15 (of 91 total)
  • Plugin Contributor Yani Iliev

    (@yaniiliev)

    Can you try the other theme and see if it causes the same issue?

    manajoe

    (@manajoe)

    Hi,
    I tried with several other themes, still the same issue. I just tried and deactivated all other plugins, but still no change.
    Thanks
    Mana

    Plugin Contributor Yani Iliev

    (@yaniiliev)

    @manajoe
    Okay, the next thing that you should try is to delete the problem event(s) and create new ones. If this is still an issue, I’ll need a temporary user to login and check the website myself.

    manajoe

    (@manajoe)

    Hi,
    deleting the events didn’t help. I updated to WP 3.1.4, deleted the plugin, deactivated all other plugins, reinstalled all-in-one, created a new calendar page, added an event, but still the same issue.
    How can I send you the login information for the test user?

    Plugin Contributor Yani Iliev

    (@yaniiliev)

    @manajoe
    Send it to yani at the-seed dot com

    Jonatello

    (@jonatello)

    I’m not alone!

    I’ve been having this same exact problem, posted about it on the seed site before the comments/bug-reports section was removed in anticipation for the coming update.

    I’ve tried disabling all other plugins: no luck

    I’ve tried creating other test events: no luck

    I see manajoe has been brave enough to try switching themes already to no avail.

    Hopefully this gets resolved, since this is the one plugin with exactly the right mix of what I need…if only it worked.

    manajoe

    (@manajoe)

    Hi yani,
    could you find out something about this problem? I saw that you created a test event…
    Greetings
    Mana

    AnnieMarie317

    (@anniemarie317)

    Hi there, I’m having the exact same issue. I get a 404 error on all of my single view event urls… all of them seem to end in “?instance_id=”

    http://www.rinconvacations.com/ai1ec_event/birthday-of-luis-munoz-marin/?instance_id=88

    http://www.rinconvacations.com/events.html

    any help would be awesome. I have deleted, re-added, deactivated plugins, all to no avail.

    thanks

    shivaji

    (@shivaji)

    I am also having the same issues with my site.

    Anyone to highlight on the issue? Did anyone get it fixed?

    theDiz

    (@thediz)

    Also having this or a similar issue. Event details works fine without an instance ID in the as a GET variable (?instance_id= -OR- missing entirely), but as soon as you add one (?instance_id=3) there is a fatal error. Here’s the stack trace if that helps at all:

    Fatal error: Uncaught exception 'Ai1ec_Event_Not_Found' with message 'Event with ID '4690' could not be retrieved from the database.' in /apps/home/dshtest/public_html/cgi-bin/wordpress/wp-content/plugins/all-in-one-event-calendar/app/model/class-ai1ec-event.php:347 Stack trace: #0 /apps/home/dshtest/public_html/cgi-bin/wordpress/wp-content/plugins/all-in-one-event-calendar/app/helper/class-ai1ec-events-helper.php(63): Ai1ec_Event->__construct(4690, 1) #1 /apps/home/dshtest/public_html/cgi-bin/wordpress/wp-content/plugins/all-in-one-event-calendar/app/controller/class-ai1ec-events-controller.php(482): Ai1ec_Events_Helper::get_event(4690) #2 [internal function]: Ai1ec_Events_Controller->event_content('') #3 /apps/home/dshtest/public_html/cgi-bin/wordpress/wp-includes/plugin.php(166): call_user_func_array(Array, Array) #4 /apps/home/dshtest/public_html/cgi-bin/wordpress/wp-includes/post-template.php(167): apply_filters('the_content', '') #5 /apps/home/dshtest/public_html/cgi-bin/wordpress/wp-content/themes/KU-DSH/single.php in /apps/home/dshtest/public_html/cgi-bin/wordpress/wp-content/plugins/all-in-one-event-calendar/app/model/class-ai1ec-event.php on line 347

    As a temporary solution, I’ve thought about using ModRewrite to remove instance id’s (we don’t use any recurring events… yet). I’m not sure if this works, but I’m thinking the rule would look something like
    RewriteRule ^(.*)\?instance_id=([0-9]+)$ $1 [L]

    sglee2120

    (@sglee2120)

    I am having the very same issue:

    The details page is blank except for the title of the event.

    I haven’t tried a different theme, but I’ve deactivated all other plugins except for 2 that are necessary for the theme I’m using which is Molitor’s Politico. It requires Option Tree and WP-PageNavi, so I don’t think I it’s ok to deactivate them.

    But again, I’ve deactivated all the others. Same error: blank details page.

    I created new events with the other plugins deactivated. Same problem.

    http://www.alec-destroys-democracy.org

    I’ll be happy to create a temp user if you will be able to deal with this. But I’d like to hear from you first. I know you are all very busy.

    Thanks so much. This does seem like a good calendar, if all the features would work.

    Susan

    sglee2120

    (@sglee2120)

    Hey, Yani,

    Are you progressing at all on this odd problem? I know I am, and I bet we all are, waiting with bated breath. LOL.

    thanks so much,
    Susan

    Jonatello

    (@jonatello)

    ooo more people…this is a hopeful sign i hope 🙂 lol

    Jonatello

    (@jonatello)

    sglee2120: by the way, i checked out your site and yeah that’s EXACTLY how mine looks (the problem, that is…not the whole website obviously lol)

    Jonatello, LOL right back at ya.

    It does seem hopeful–or not–that this is affecting more than one of us. But I certainly hope we hear from Yani soon. I’m SURE he is working hard to figure it out in addition to everything else he needs to do, but I’m going to have to try to find a different calendar pretty soon, darn it.

    good luck,
    Susan

Viewing 15 replies - 1 through 15 (of 91 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] Event details not showing’ is closed to new replies.