Support » Plugins and Hacks » [Plugin: All-in-One Event Calendar] Crashes wordpress with HTTP 500 error

[Plugin: All-in-One Event Calendar] Crashes wordpress with HTTP 500 error

  • Set it up. Updated settings.

    Page created (“Calendar”).

    But I was still getting the error message “Settings not updated”. So I went into settings and selected the same settings as before, and clicked on UPDATE SETTINGS.

    This led to http 500 error. I couldn’t see even the dashboard.

    So I had to manually delete the “all-in-one..” folder.

    When i reinstall the plugin, I see this error:

    Fatal error: Ai1ec_Settings::get_instance() [<a href='ai1ec-settings.get-instance'>ai1ec-settings.get-instance</a>]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition &quot;Ai1ec_Settings&quot; of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/mydomain/public_html/wordpress/wp-content/plugins/all-in-one-event-calendar/app/model/class-ai1ec-settings.php on line 242

    What’s up?


Viewing 7 replies - 1 through 7 (of 7 total)
  • Just to add: I tried this on a fresh install on my local mac osx wordpress install.

    Installed fine. saved the settings once. The second time I saved the settings, the whole thing disappeared. Only the “UPDATE SETTINGS” button shows.

    When I then go to add a new event, it shows me “plugin has been installed but not configured”.

    On a fresh install !!

    Is this a serious plugin?

    Plugin Contributor Yani Iliev


    A couple of things: the plugin works out of the box on many installs. The reason that it fails for you on 2 separate installs must be the hosting.
    You say that you are using the plugin on your local mac osx. Did you configure AMP yourself or you are using a solution like MAMP?
    Also, make sure that you have disabled all sort of caching plugins and tools before using the plugin. You can enable these later, after setting up the plugin.

    Plugin Contributor Yani Iliev


    If you are using W3 Total Cache – disable it while configuring the plugin.

    I am getting the same error on WPEngine. The plugin worked fine when running it locally but I had the exact same error when trying to install it on my host (WPEngine). I’m not using a caching plugin but WPEngine has caching built in. I’m not sure it can be turned off.

    I found a panel to turn off WPEngine’s built in caching. Activation worked. This should be highlighted on the plugin’s description.

    I am having the same issue as @yquez with WPEngine. In class-ailec-settings.php around line 422 you have

    if( defined( 'W3TC' ) ) {
      wp_cache_delete( 'alloptions', 'options' );

    If I take ouf the if statement and just call ‘wp_cache_delete’ everytime it works. Do you see a problem with this?

    I am having a very serious problem.. last week the entire plugin directory was emptied of all files. I feel the site was hacked, and have seen numerous warnings on line about this plug in and its effects on a stable wordpress site.

    The calendar tables are still present, but now

    1. I needed to manually re-upload the plugin to the correct directory
    2. the plug in does NOT appear in the inactive list in wordpress… even tho it is in the correct plugins directory

    Any ideas about this ?? I am really dyin

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] Crashes wordpress with HTTP 500 error’ is closed to new replies.