WordPress.org

Forums

All-in-One Event Calendar
[resolved] calendar navigation buttons link incorrectly (15 posts)

  1. djf88
    Member
    Posted 3 years ago #

    I am using the all-in-one event calendar plugin.

    The buttons for navigating up/down months or years (among other buttons which I am not concerned with) are forming links beginning with # for some reason?
    e.g. If I click to move forward one month my URL changes from /calendar/ to /calendar/#action=ai1ec_month&ai1ec_month_offset=1&ai1ec_post_ids=
    If I replace the # with ? the calendar links will work as desired.

    Can anyone tell me in which file I can correct the way these links are formed? or perhaps why this is happening at all?
    I've checked calendar.php in the /themes-ai1ec/vortex folder and the buttons are being called using <?php echo $view ?> but that's as far as I've managed to get..

    Thanks in advance for any help

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. djf88
    Member
    Posted 3 years ago #

    Can anyone help me here?

    I found a thread on changing the link for the 'print' button: Print Button Not Working.

    I cant find the month/year links anywhere though..

  3. djf88
    Member
    Posted 3 years ago #

    Ok, I switched themes to Twenty Eleven and the links still begin with # however they work in this theme.

    So this must be a theme conflict - I've checked the suggestions for theme conflicts and none of them resolve my problem.

    Has anyone else had this issue? or can anyone tell me where I can change this # to a ?

    Thanks

  4. Richard
    Member
    Posted 3 years ago #

    Hi djf88,

    Thank you for diagnosing this as a theme conflict. Sorry to hear that the recommended solutions here (http://help.time.ly/customer/portal/articles/676565-my-wordpress-theme-has-a-conflict-with-the-ai1ec-what-can-i-do-) did not resolve the issue.

    Are you able to provide us with the theme or email us access to your WP and FTP admin (help@time.ly) and we will then try to work out what is going on.

  5. Richard
    Member
    Posted 2 years ago #

    It has been over 2 weeks with no additional posts, so I am marking this thread as "resolved."

  6. djf88
    Member
    Posted 2 years ago #

    This has not been resolved.

    I have granted access to a member at time.ly - they advised me to upgrade to premium - that hasn't fixed my problem.

  7. Richard
    Member
    Posted 2 years ago #

    Hi djf88,

    Thank you for bringing this to my attention. I have changed this thread back to "not resolved."

    Our Technical Support Specialist will be emailing you the names of the files where you can change # to a ?. However, please bear in mind that these files will be overwritten during updates, so this is probably not a long-term solution.

  8. Ula Szczepaniak
    Member
    Posted 2 years ago #

    @djf88
    If you want to change the link please open
    the wp-content/themes-ai1ec/vortex/calendar.php and change the line 16:
    href="#action=ai1ec_<?php echo $key; ?>&ai1ec_post_ids=<?php echo $selected_post_ids; ?>">
    with
    href="?action=ai1ec_<?php echo $key; ?>&ai1ec_post_ids=<?php echo $selected_post_ids; ?>">

    Regards

  9. Ula Szczepaniak
    Member
    Posted 2 years ago #

    @djf88

    Continuation of the last post:

    To add these changes to the navigation link on the month view
    please put in line 5 in the month.php file:
    href="#action=ai1ec_month&ai1ec_post_ids=<?php echo $post_ids; ?>">
    with
    href="?action=ai1ec_month&ai1ec_post_ids=<?php echo $post_ids; ?>">

    In the other views you have to make similar changes.

    Regards

  10. djf88
    Member
    Posted 2 years ago #

    Hello Ula Szczepaniak, thank you for getting back to me.

    The replacement code you have suggested above doesn't seem to fix the pagination links, as they still begin with a #.

    They are being called in the files (month.php, week.php and oneday.php) using this bit of code:

    <?php foreach( $pagination_links as $link ): ?>
      		<a id="<?php echo $link['id']; ?>"
      			class="ai1ec-load-view btn"
      			href="<?php echo esc_attr( $link['href'] ); ?>&ai1ec_post_ids=<?php echo $post_ids; ?>">
      			<?php echo esc_html( $link['text'] ); ?>
      		</a>

    more specifically:

    <?php echo esc_attr( $link['href'] ); ?>

    Do you know which file these variables are defined? (if that makes sense)

    Thanks again

  11. Ula Szczepaniak
    Member
    Posted 2 years ago #

    @djf88
    I'm afraid we have to find another way to fix it.
    I think you have a JS error that is preventing AJAX from functioning.

    Please let me know if you have a situation like this:

    XMLHttpRequest cannot load http://www.yourdomain/folder/wp-admin/admin-ajax.php. Origin http://yourdomain.com is not allowed by Access-Control-Allow-Origin.

    So I guess WP is physically installed at http://www.yourdomain.com/folder, but it is also mapped to the yourdomain.com domain and that's where the site is being viewed from. This seems to be causing an XSS issue. Sometimes this can be fixed by adjusting WP general settings, and if not please send me access to your site, help@time.ly with "[Technical Support] # issue" in the title.

    Thanks

  12. djf88
    Member
    Posted 2 years ago #

    Hi,

    WordPress is installed in the root of my site and I am able to view the link posted without seeing the error described, I simply see '0'.

    I think I'm going to go with a different plugin, but thank you for your help

  13. KevinP.
    Member
    Posted 2 years ago #

    I had this problem myself. For me the fix was to go to Settings > General and set up my URL and site URL to the correct address.

  14. Ula Szczepaniak
    Member
    Posted 2 years ago #

    @KevinP - thank you for posting the solution which worked for you.

    @djf88 - I am sorry to hear that. We are keen to work with you so that you can continue using the Ai1EC. Please email up-to-date login access (WP and FTP) to help@time.ly and write "For Technical Support Specialist" in the title. I am going to make it a priority to look into this for you.

  15. djf88
    Member
    Posted 2 years ago #

    Thank you for all your help, unfortunately we were unable to resolve my problem.

    I am marking this topic resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • All-in-One Event Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic