All-in-One Event Calendar
[resolved] Calendar isn't displaying at all (9 posts)

  1. DanChorley
    Posted 4 years ago #

    My previous thread was prematurely resolved, I think because I didn't pastebin my code - my bad!

    Lets try again:



    I am using the latest version of WordPress in a Multisite installation, which can be accessed here: http://kube.danielchorley.co.uk/ with the following details:

    Username: dan
    Password: dannoth
    (case sensitive - all lowercase)

    The calender is currently setup, as default, to display on /calendar

    However, it won't display. I have tried versions 1.7, 1.6.1 premium, and it is currently rolled back to 1.5. Alas, it still does not display, and it seems nothing shows up in the source either?

    Any help with this would be much appreciated, as this is an excellent plugin and it would be a shame to have to use something else in its place!

    Thank you in advance.


    Here is a link to the code for my full-width template, which is the one I am using for this page.


    Thank you again!


  2. Richard
    Posted 4 years ago #

    Hi Dan,

    This looks like the same post which you put on our support forum. For the convenience of other users, I am pasting the link to our answer here:


  3. DanChorley
    Posted 4 years ago #

    Have done. Just been putting the question in many places due to the lack of response.

  4. Richard
    Posted 4 years ago #

    No problem, Dan. Sorry it took so long for us to get back to you. We are getting on top of things now :-)

  5. DanChorley
    Posted 4 years ago #

    For those who are interested with similar issues to this (calendar not displaying) I have managed to resolve the issue for my theme.

    Find the append_content function in app/controller/class-ai1ec-app-controller.php

    Find the following:
    if( in_the_loop() )
    Replace with:
    // if( in_the_loop() )

    Now [ai1ec] works on my pages.
    Hope this comes in handy.

  6. sparx
    Posted 3 years ago #

    DanChorley - Your advice above worked perfectly on the free version, but when I upgraded to premium I no longer had this line and couldn't comment it out. Now I am back to square one with my calender not showing again.

    Does anyone know how to get the premium version to display?

    Many thanks in advance,


  7. sparx
    Posted 3 years ago #

    Ignore above comment, I must have missed that line in the premium code. It is still there and adding // before it does still work.

    Thanks to DanChorley!

  8. DanChorley
    Posted 3 years ago #

    Glad you found this solution worked!
    I cannot tell you how infuriating it is to find a load of un-answered support topics to a problem, and for people to solve them for themselves and not post how they fixed it!

  9. sevb
    Posted 3 years ago #

    <3 this worked, Timely should really add this to their F&Q to save users a headache

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • All-in-One Event Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic