WordPress.org

Support

Support » Plugins and Hacks » All-in-One Event Calendar » [Plugin: All-in-One Event Calendar] Ajax doesn't work with forced admin SSL

[Plugin: All-in-One Event Calendar] Ajax doesn't work with forced admin SSL

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Yani Iliev

    @yaniiliev

    @tharrisn
    How do you force SSL?
    Is your SITE_URL defined properly after your force SSL?

    I force SSL on login/admin through “wp-config.php” line 54 (WordPress 3.3.1)

    /** Force all logins and all admin sessions to happen over SSL. */
    define(‘FORCE_SSL_ADMIN’, true);

    SSL works perfectly with the rest of the site. I’ve got WooCommerce installed for commerce and it’s working great too. The only change in the site URL is of course the protocol prefix of HTTPS.

    AI1EC is choking whenever there is an ajax call. It appears to work well everywhere else. If I comment out “define(‘FORCE_SSL_ADMIN’, true);” in wp-config.php then the ajax calls work fine.

    Plugin Contributor Yani Iliev

    @yaniiliev

    @tharrisn
    File: app/controller/class-ai1ec-calendar-controller.php
    Line 588: 'ajaxurl' => admin_url( 'admin-ajax.php' ),

    Change the line to:
    'ajaxurl' => site_url( '/wp-admin/admin-ajax.php' ),

    Save the change and try again.

    Thanks for the quick response.

    Ok, made the change but ajax calls still fail while in the admin area. However, ajax calls while viewing a calendar, i.e. clicking previous or next month work now.

    For example while creating a new event or editing an existing event these items don’t work: clicking the “Add” button for Event Tags, clicking the Repeat checkbox doesn’t create an overlay with the repeat dialog box. There may be others but those are ones I use all the time. Nothing happens when performing either of these operations with “define(‘FORCE_SSL_ADMIN’, true);” in wp-config.php.

    Plugin Contributor Yani Iliev

    @yaniiliev

    @tharrisn
    I will be able to reply you no earlier than Monday :/

    Hi,

    Has there been any update on this. I found a similar issue regarding an SSL enabled network/multiuser WordPress 3.3.1 installation. Disabling SSL fixed the issues. I also changed the ajaxurl which at least prevented the Calendar going into continuous load mode.

    Thanks,

    @yani – Your solution seemed to work for the latest version or wordpress and the ajax event calendar on a website running under a ssl admin area. Seems to have fixed the calendar not showing events and the event link when clicked now displays the info it’s supposed to rather than just saying loading…
    Thanks!
    ——————-
    Except I changed it on this file and line number as I couldn’t find the one your referenced.:

    File: ajax-event-calendar.php
    Line 538: ‘ajaxurl’ => admin_url( ‘admin-ajax.php’ ),

    Change the line to:
    ‘ajaxurl’ => site_url( ‘/wp-admin/admin-ajax.php’ ),

    Save the change and try again.

    lol that was for the wrong calendar plugin I posted about but it fixed it for me on the ajax calendar as well …

    I am having an issue with the All-in-one Calendar though. I’m using forced admin ssl and everything seems to work fine until I try to post an all day event on Monday and have it repeat every monday…

    If I don’t make it an all day event and I select the time frame to be all day, it errors out to a 404 page. If I make the time selection a little less than all day like 23 hours long, it posts fine…

    I can post all day events on all other days that repeat each week with no troubles.

    I checked your fix above and that is already included in the latest download of the plugin.

    oh yeah, in the console it errors saying:
    “NetworkError: 404 Not Found – https://www.mydomain.com/wp-admin/post.php

    This is the error in firebug once the update button is clicked …

    I can post an all day event for monday to repeat each day with no problems, I can even have it repeat monthly on the second week or whatever, but NOT each monday in each week, or even one time a year …

    Trying to post it as an all date event Weekly on Monday until June 5, 2012 only displays the first one and no others are displayed but the page doen’t go to a 404 and it looks like it is saving with no error in firefox console…

    Also, if I set the all day event for Weekly on Sun, Mon, Tue – forever, all the events show up on Sun & Tue, but all the Mondays are absent on the calendar …

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: All-in-One Event Calendar] Ajax doesn't work with forced admin SSL’ is closed to new replies.
Skip to toolbar