Support » Plugins and Hacks » [Plugin: Akismet] Server Configuration Error

  • Resolved kabitzin


    I’m using v2.5.1 of Akismet and I get the following error:

    The key you entered could not be verified because a connection to could not be established. Please check your server configuration.

    The key below was previously validated but a connection to can not be established at this time. Please check your server configuration.

    However, all the server connectivity rows below show the servers as accessible. How are we supposed to know what to check in the server configuration to connect to This error message is very cryptic and I noticed the problem as of 2.5.0.

Viewing 12 replies - 1 through 12 (of 12 total)
  • If you update to version 2.5.1 do you still get the error?

    Yes, I am already using 2.5.1

    Can you give this debug plugin a try – – it will write details about the HTTP response to your web server error log. Send us the results – – and hopefully that will provide us with the data we need.

    I’m having the exact same problem on 3 blogs I host on the same machine. They have all been working fine for months and months then just about a week or two ago this started happening to me. It says:

    The key below was previously validated but a connection to can not be established at this time. Please check your server configuration.

    but the servers all show that they are accessible. It’s also not checking for SPAM anymore. WordPress 3.0.4 and Akismet 2.5.1. I will give the debug plugin a try and let you know that I come up with.

    Update, that debug plugin seems to crash my WordPress install pretty hard. Just continuous blank white pages and nothing logged in the Apache error_log.

    If it is crashing you should have details in the error logs. It’s possible your server is logging PHP errors some where else besides the Apache logs.

    I found the error, I just changed display errors to on in my php.ini file:
    Fatal error: Cannot use object of type WP_Error as array in /var/www/html/dansrandomness/wp-content/plugins/wp-http-error-log.php on line 14

    Hmm, that’s no good. Are any HTTP requests from WordPress making it out okay?

    I’ve reviewed the reports from a few other people and it seems that in some cases the HTTP request timeout was getting hit and the connections would die. I’ve increased the timeout in the development version of the plugin, which if you want to try out you can get the files from – Just keep in mind this is a development version and is may be in a state of flux and or not working at any given point.

    Hmmm….yes and no it seems. My Google Analytics seemed to be having trouble also as I was getting this on my Dashboard

    No Analytics account selected. Double check you are authenticated with Google on Google Analyticator's settings page and make sure an account is selected.

    Even though it was correctly setup. If I go to the settings though for it and disable cURL then it seems to work OK and displays my Google Analytics stats on my dashboard. This is my own server (Fedora 14) and I don’t think I have changed anything that would have caused it. Google Analytics seems to stop working about the same time Akismet stopped though. Maybe the two are related? I will get the dev trunk a try though and see if anything changes. Thanks!!

    I just installed the dev build and it seems to be working alright. On the config page it says “This key is valid.” and when I told it to re-check for SPAM it checked and flagged all the SPAM comments. I will run with it this way for a day or two and see if the problem is resolved with this build. Thanks again!!!

    No problem. If you run into problems definitely drop us a note at

    Looks like that got it. It’s been catching SPAM again ever since I installed the dev build. I’m going to wait until the final version to deploy it on my other two blogs though (don’t want to piss off wifey if I break them). Thanks so much for your help!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Akismet] Server Configuration Error’ is closed to new replies.