Support » Plugin: Ajaxify WordPress Site(AWS) » [Plugin: Ajaxify WordPress Site(AWS)] This is a great plugin except for a few minor issues…

  • Resolved echpoh


    if i click on the meta link login or register (ajaxify)


    there will display odd wordings like

    function wp_attempt_focus(){ setTimeout( function(){ try{ d = document.getElementById('user_login'); d.focus();; } catch(e){} }, 200); } wp_attempt_focus(); if(typeof wpOnload=='function')wpOnload();


    ajaxify.js line 206

    jQuery(“#ajax-search”).ajaxify(); will trigger a javascript error

    because of this, ajax search doesnt work

    fyi: #ajax-search is in the document,
    because when i run

    jQuery(“#ajax-search”).hide(); — > there is no error

    that means the .ajaxify() is causing the error.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author manishkrag


    HI echpoh,

    Thanks for considering 🙂

    For issue 2 I have checked in my several wordpress settings and it seems perfectly OK, also I have get feedback from several person regarding this and Search is working fine.

    I am assuming that your jQuery is not working perfectly that is why you are getting some js errors.

    NOTE: Be sure that your search form ID should be ‘searchsubmit’ and inputbox OD should be ‘s’.


    What about issue #1?

    what about themes that do not have a search button such this

    Im using this theme now, perhaps you can test it out with this free theme

    and also figure out whats wrong with the jQuery (if any)

    Plugin Author manishkrag


    Here AWS not installed.

    where AWS not installed?

    Plugin Author manishkrag


    Sorry I understood wrong.

    Yes in this in this theme search will work just after intallation as this theme having search form ID ‘searchsubmit’ and input box ID should be ‘s’.

    if your theme does not have same then change in ajaxify.js file or in your theme the same.

    I’ll test with this theme in my local.

    For issue 1 I’ll check in in today night. 🙂

    have u had any try with the problem?

    today i found another problem

    we cannot use the <!–more–> tag on our post because

    the Read more link is going to have a #more hash tag apend to it, and if we click on it its not going to load anything..

    my suggestion is not to trigger ajax with just the # instead use the #!/

    like used on twitter for example!/search/cocacola

    Plugin Author manishkrag


    Actually I am too much packed up with my company jobs.
    I’ll look into these in weekend 🙂

    Plugin Author manishkrag


    Hi Issue 1 is fixed,
    for you just follow the below instruction:

    In line number 65 in ajaxify.js file replace below code

    After adding the above code all the link having wp-admin or wp-login will reload page.


    Plugin Author manishkrag

    I have checked the theme code and got that in header.php file they are adding core js file using script tag which is not good. And in the same file in line number 40 wp_head(); present which should present just before the end of head tag.

    So just remove wp_head(); from line 40 and add the same just before the end of head tag in php tag, thus your problem will be solved.

    And download the latest version of the AWS then your first issue also resolve.

    Plugin Author manishkrag


    Let me know the status 🙂

    thanks ! wonderful, il give it a try tomoro

    Hey basically the only changes to the 1.3.3 is the ajaxify.js file?

    is so then i already have done the changes based on your instigation

    so it works great now.. but there is still 1 more thing
    for links with hash such as comment links

    the ajax system is tricked to load a page named “comment-7” and therefore nothing happens…

    so that’s why i ask i suggested to use /#!/ to trigger ajax like what twitter does!/search/cocacola

    Plugin Author manishkrag


    I have checked your site your searched functionality not ajaxified.

    Change in line 214 sibling‘ to ‘find‘.

    thanks… byw ive made some changes regarding the effect of loading.. i find fading out completely is too dramatic.. so i have opted for a slight dim before load.. if u like it, go ahead and incorporate this in your next version

    so do u understand what im talking about with the hash thing?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Ajaxify WordPress Site(AWS)] This is a great plugin except for a few minor issues…’ is closed to new replies.