Event Calendar
Calender dont show since yesterday (21 posts)

  1. chris1407
    Posted 4 years ago #

    I make no changes. And today i came to my Website and it dont shows up.

    Firebug gives me an error:

    TypeError: m.curCSS is not a function

    on file: jquery.fullcalendar.min.js


    But i changed nothing on that file and i installed no new plug-ins and i dont update any plug-ins last time.

    here is a link: http://moccamaker.de/testseite/

    Thx for help


  2. mulegoat
    Posted 4 years ago #

    I am having the same problem on all my sites using this calendar. All stopped working a couple of days ago. Have tried disabling other plugins using jquery, doesn't work.


    Any help would be much appreciated


  3. chris1407
    Posted 4 years ago #

    On your site are the same Errormessage like on my site. There is something wrong with the Javascript i think.

  4. chris1407
    Posted 4 years ago #

  5. mlustig
    Posted 4 years ago #

    I am having the same problem. Calendar doesn't show up at all. Thanks chris1407 for the link above. Should we expect this plugin to be updated, or should I retrofit my jquery version?

  6. chris1407
    Posted 4 years ago #

    I hope there will come an update for this plugin.

  7. hsnshw
    Posted 4 years ago #

    I hope an update comes soon... It is the only calendar plugin I have used and enjoyed using.

  8. chris1407
    Posted 4 years ago #

    Search for a link like this in your template:


    and change it with this:


    Then it will work.

  9. mlustig
    Posted 4 years ago #

    Chris, this sounds like a an excellent workaround. Can you be a little more specific about where to search for this link? Which template is it in, and how would I search it?


  10. chris1407
    Posted 4 years ago #

    Open your site in Browser and then look to the sourcecode. Search for jquery.min.js or jquery.18.js or similary. When the Calender stop to work without that you update a plugin or something, then in your theme must be a link like this: https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js

    This link means that your theme will always load the newest jquery version.

    Normally the link is in header.php but it can be in a other file too.

    You can download your website via ftp to your computer and user the tool windows grep to search for the string.

    Search for jquery and edit the link with this: https://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js

    Then check if all running well.

    Sorry for my bad english.

  11. Tsunamy
    Posted 4 years ago #

    chris1407 thank you for your sharing. For me it worked but was in the functions.php of my project instead of the Header. Thank you.

  12. helenbakker
    Posted 4 years ago #

    What worked for me was taking out another plugin which wasn't working well with the Event Calendar. Simple deduction, and easy to do since the plugin wasn't really useful anyway.
    Sometimes you need all your plugins and then I guess Chris' solution works too.

  13. mlustig
    Posted 4 years ago #

    I have searched through all of the php files at Dashboard>Appearance>Editor in my child theme and the parne theme. I can't find the link https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js or any link containing "Jquery".

    I searched through all the files at Dashboard>Plugins>Editor>Ajax Event Calendar and can't find any link related to jquery.

    What am I missing?

  14. chris1407
    Posted 4 years ago #

    Try to make a copy from the site via ftp to your local computer and search with windows grep for jquery string. There must be a jquery lib.

  15. Shotta TV
    Posted 4 years ago #

    You need to install this plugin and it restores JQuery for you,.... fixed our calendar anyway! Bless http://www.shotta.tv

    Use this plugin and the calendar reappears!!


  16. mlustig
    Posted 4 years ago #

    Installing the restore-jquery plugin did not fix my problems.

  17. mulegoat
    Posted 4 years ago #

    mlustig - and anyone else who can't find the jquery url call in their themes, it could be because the url is slightly incorrect - its not https - but http (at least it is in the case of my theme).

    So - search in your theme for http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js

    and replace with...


    Then it should work. This is easier to do within an authoring program that allows you to search the entire local site directory. In Dreamweaver for example, using Ctl F key and selecting 'Entire Local Site' will search through all theme and plugin files.

    It definitely works

  18. kalle0
    Posted 4 years ago #


    I cant find that string in my homepage files. I download all files and search with Win7 search "inhalt:http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js" and also with just some parts, it dont work.

    if I just search in the source code of my homepage I see in line 35 header area "<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=2.4.4'></script>`

    I dont know what I shoudl do. I also re-install, nothing changed.

    Other webside, same webspace, also wordpress, also with ajex calender works well.

    Maybe somewhere have a idea?

  19. chris1407
    Posted 4 years ago #

    Search only for this string: jquery.min.js

    And try this tool. http://www.wingrep.com/

  20. kalle0
    Posted 4 years ago #

    I searched also just for this string, but I cant found. I tried today again with deactivating plugin.

    First I deactivate all, and set theme to standart, then Calendar works. Then I set to my Theme, Calendar works. Then I activate each plugin and check calendar.

    I found "WP Socializer" make the problems. I deactivate and delete it, now all things are fine. I just nit understand, before it works fine all together, just since some days calendar stop working because of that.

    I will try your tool to find the string.

    Thanks for now

  21. Fastone
    Posted 3 years ago #

    Hey folks,

    I have now a problem with WP Calendar, javasript and some ajax hack I have spent too much time on. I just cant seem to fix this crap, and I'm not a hardcore programmer.

    The graphical calendar is not showing, just the table headers.

    I think I have found the problem, but I just cant understand how the H this is happening. I have other WP plugins loaded to, but deactivating them doesn't help.

    Some ajax tries to get loaded in the header, but the path in the code looks like this:

    /* <![CDATA[ */
    var WPCalendar = {"ajaxUrl":"http:\/\/www.moneel.no\/wp-admin\/admin-ajax.php"};
    /* ]]> */

    What's up with the trailing slashes!?

    Hope some of you knows something about this,


Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.