Support » Plugins » [Plugin: After the Deadline] Plugin Updater Thinks Version 0.421 is Newer Than Version 0.49

  • Resolved Chip Bennett

    (@chipbennett)


    Theme Review Admin

    So, while poking around the repository today, I noticed that version 0.49 of AtD was added four days ago (08Dec09).

    Strangely, although I have version 0.421 installed, I am not notified of a new version.

    When I use “Add New Plugin” feature from within WordPress, and serach for AtD, clicking the Install button in the search results opens the AtD repository page in the lightbox window. However, where the Install/Upgrade button normally is, the following message is displayed:

    Newer Version (0.421) Installed

    This makes no sense.

    Is this an issue with AtD, or with the updater/update-checker?

    http://wordpress.org/extend/plugins/after-the-deadline/

Viewing 4 replies - 1 through 4 (of 4 total)
  • I suspect this is an issue with how version numbers are compared. I’m looking into creating a work-around for this.

    🙂 My fault for using wonky version numbers (sorta). WordPress uses PHP’s built-in version_compare function. http://us3.php.net/version_compare

    I’ll likely post an update to the plugin today with a version number bump to resolve this issue. I just have one more issue to troubleshoot.

    — Raphael

    Chip Bennett

    (@chipbennett)

    Theme Review Admin

    Awesome! Thanks again, Raphael!

    Chip Bennett

    (@chipbennett)

    Theme Review Admin

    Just updating the resolution status. The version 0.49001 properly reported itself, and I was able to upgrade.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: After the Deadline] Plugin Updater Thinks Version 0.421 is Newer Than Version 0.49’ is closed to new replies.