WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: After the Deadline] Changes HTML Tags to Non-Compliant ALL-CAPS

[Resolved] [Plugin: After the Deadline] Changes HTML Tags to Non-Compliant ALL-CAPS

  • Chip Bennett

    @chipbennett

    Theme Review Admin

    Today I installed the After The Deadline plugin to test it out.

    I use the HTML editor by default. I opened a draft post, and clicked the [PROOFREAD] quicktag button. AtD scanned the draft and returned no errors. However, the plugin apparently changed all of my DOCTYPE-compliant lower-case HTML tags to non-compliant ALL-CAPS tags.

    I can find no way to modify this behavior. The plugin offered no option to ignore whatever “rule” modified my HTML tags, and there are no configurable options on either the AtD plugin options page or on my profile page.

    Why on earth would a modern proofreading plugin change HTML tags to a format that has not been standards-compliant for several years now?

    http://wordpress.org/extend/plugins/after-the-deadline/

Viewing 15 replies - 16 through 30 (of 32 total)
  • Chip Bennett

    @chipbennett

    Theme Review Admin

    Oh, I completely missed your earlier reply. Some sort of time-warp thing happening.

    Glad to know I was able to help diagnose the problem!

    Yeah this one is tricky. I haven’t replicated your setup with a /wordpress/ directory yet but I plan to. So the visual editor and HTML editor both call the same thing (admin_url()) to setup the path they post to. One working and the other not is very strange indeed. It’s either some very strange bug and I’ll track it down or a plugin or something modifying what admin_url() returns. I don’t know which yet.

    Could you tell me what plugins you have installed? That info may or may not help me. I’m setting up a few long running tasks and once these are going I’ll crunch through this problem.

    Chip Bennett

    @chipbennett

    Theme Review Admin

    Strange; I thought a /wordpress/ directory was common/normal practice.

    I doubt I’m using any plugins that would be modifying admin_url(), but I have listed my active plugins for you, in your draft post on chipbennett.net.

    Hopefully you can figure out what’s going on. I would love to be able to use AtD!

    Ok, I noticed you have 25 or so plugins loaded. 🙂 Part of the power of the WordPress platform.

    Here is the code AtD uses to reference the admin-ajax script for the Visual Editor:

    $init_array[‘atd_rpc_url’] = admin_url() . ‘admin-ajax.php?action=proxy_atd&url=’;
    $init_array[‘atd_ignore_rpc_url’] = admin_url() . ‘admin-ajax.php?action=atd_ignore&phrase=’;

    Here is the code AtD uses to reference the admin-ajax script for the HTML editor:

    echo “AtD.rpc = ‘” . admin_url() . “admin-ajax.php?action=proxy_atd&url=’;\n”;

    You’ll notice they both refer to admin_url() + “admin-ajax.php?action=proxy_atd&url=”

    I suspect something is changing the constant admin_url() depends on. Could you try disabling all the other plugins, spell check in the HTML editor, and see if it works then? If it does then that tells me one of them is eating this value. In which case you’d want to reenable them one by one to find out which one is causing the problem.

    If this sounds like too much hassle, I can tell you how to hard code the correct value into after-the-deadline.php so it just works but if a plugin is clobbering this value, I’d like to notify the author.

    Chip Bennett

    @chipbennett

    Theme Review Admin

    Okay, I disabled all plugins except for AtD.

    Same problem. I get the same error when using the HTML editor.

    So, that (probably) eliminates a plugin conflict/issue.

    I think I have a development install on a thumb drive somewhere, with XAMPP. (I used to have a LAMPP install on the Kubuntu laptop, but I did a fresh install of / when I upgraded to Karmic, and haven’t yet re-installed LAMPP.) I wonder if I can replicate the problem under XAMPP?

    I took a look through the WP source and noticed admin_url() is defined in three places. Two of them define it as an empty function. I’ve added a check in the plugin to check if you’re the lucky winner of one of these empty functions and to work around it.

    http://killall.dashnine.org/atdforchip.tgz

    Let me know if it works for you.

    Chip Bennett

    @chipbennett

    Theme Review Admin

    Hmm… doesn’t seem to work for me. I tried:

    1) Overwriting existing AtD folder. Still works in visual but not in HTML editor.

    2) Deleting existing AtD folder and re-uploading. Still works in visual but not in HTML editor.

    I’m sure you have more important things to be doing today. Happy Thanksgiving out there in the District!

    (I spent many Thanksgivings flying into/out of BWI and National, when my parents were at Pax River. Hope it’s still as beautiful now as I remember it.)

    Problem solved. I left a line of code in one of the JavaScript files that reset the AtD.rpc value to /wp-admin/admin-ajax.php. I caught it using Firebug’s variable watch capability.

    Thanks for working with me on catching this. The HTML editor proofreader was probably broke for a lot of people with installs similar to yours.

    I just committed it to the WP.org SVN repository. It’ll probably take a 15-30 minutes before it goes live but you should be all set once you download it.

    — Raphael

    Oh and happy thanksgiving 🙂 DC is nice around this time of year but I’m in Detroit now visiting family.

    Hi Raphael, I’m having the same issues. I just installed the plugin today. FF 3.5.5, Windows, WP 2.8.4. The plugin works in the visual editor but not in the HTML editor (where I do most of my work). I get the error message:

    There was an error communicating with the spell checking service.

    error: undefined

    I could switch to the visual editor, do the grammar check (this works), then switch back, but my HTML will be stripped away.

    Thanks.

    I just applied AtD version 0.421 and got the same results.

    Chip Bennett

    @chipbennett

    Theme Review Admin

    Closer, but still not there yet.

    Now, the raw HTML gets converted to WYSIWIG, but then I get the same error message (before any proofreading markings are added, i.e. the red bar indicating a spelling/grammatical error).

    Chip, try clearing your cache. I logged into your blog and was able to check a post.

    What happens, when you click Proofread–the TEXTAREA of the HTML editor is swapped out with a div containing your HTML (your HTML gets rendered at this point). You should see the red, green, and blue markings on your text unless there were no errors.

    I did:

    This iss a test

    Chip Bennett

    @chipbennett

    Theme Review Admin

    It works!

    Awesome! Thanks Raphael!

    I have another, unrelated concern, but I will start a different thread.

    Happy Thanksgiving!

    Chip Bennett

    @chipbennett

    Theme Review Admin

    Nevermind about the other issue. It appears that it has been resolved. (HTML tags were getting stripped, but now they are not.)

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Resolved] [Plugin: After the Deadline] Changes HTML Tags to Non-Compliant ALL-CAPS’ is closed to new replies.