Support » Plugins » [Plugin: Advertising Manager] unable to add ad after moving to live site

  • everything is ok on staging site but when i moved to live site i was never able to add ads, it goes well through importing but when clicking save post request goes but reply never comes back. i use latest version of plugin. i wonder is due to server load? (30k unique visitors/100k page hits daily). the only difference in staging site and live site is W3 Total Cache plugin (with default settings)

    Header append Cache-Control "public"
    FileETag MTime Size
    ExpiresActive On
    ExpiresDefault "access plus 0 minutes"
    ExpiresByType image/ico "access plus 1 years"
    ExpiresByType text/css "access plus 1 years"
    ExpiresByType text/javascript "access plus 1 years"
    ExpiresByType image/gif "access plus 1 years"
    ExpiresByType image/jpg "access plus 1 years"
    ExpiresByType image/jpeg "access plus 1 years"
    ExpiresByType image/bmp "access plus 1 years"
    ExpiresByType image/png "access plus 1 years"

    in .htaccess to cache all static files.
    Tried to disable W3TC but problem persists.

Viewing 10 replies - 1 through 10 (of 10 total)
  • up, somehow missed to add tag. the problem persists.


    Traffic should not be the issue – especially because you are getting errors in admin rather than on your blog page. I have not tested with W3 Total Cache plugin. I will try to test with this and let you know the results.


    Having similar problems, can’t edit ads now it just times out and I get this:

    Maximum execution time of 30 seconds exceeded in /home/wp-content/plugins/advertising-manager/lib/Advman/Tools.php on line 44, referer:

    I had to download back to before I could edit adverts again.

    I had the same problem with 3.4.19 and WordPress 3.0. When I took Shaolin Tiger’s suggestion and downgraded, it worked again. There is something happening with the new version that prevents adding or deleting ads.

    I have now more accurately identified the problem.

    After rolling back to 3.4.13 I could edit, add and delete ads as I normally could in the past. Everything works properly with 3.4.13 and WordPress 3.0.

    However, when I upgrade to 3.4.19 I can no longer edit, add or delete the ads. If I try to do so, the plugin will execute as if the change occurred. But when I go back or refresh the “Edit Ads” screen, none of the changes have been saved.

    I decided to downgrade twice more to see when the error first occurred. And I got the same error for versions 3.4.18 and 3.4.17 – Ad change executed but not saved. The main difference between these versions and 3.4.13 is the addition of the counter. In the new versions (3.4.17-19), you can see how many times a particular ad space has been viewed but you cannot in 3.4.13. My guess is that this feature addition has created a bug whereby in certain circumstances all ad spaces are fixed and no changes can be made. I experimented with trying to uncheck the “collect statistics” radio button but I wasn’t able to identify this as the source of the problem.

    Bottom line: there is a bug in these new versions. I believe it has to do with the statistics feature. I will downgrade to 3.4.14-16 and tell you when the bug first appeared.

    I just tried edits in version 3.4.14 which also has the statistics feature. It works! The bug is not related to the statistics feature then. It must be something else. This is the version I am going with now.

    The only newer version I never tested was 3.4.15. But 3.4.16-19 all prevent edits, adds and deletions.

    I hope this helps.

    edwardnh: Do you have a ton of tags or categories? Newer versions of Advertising Manager load ALL of these in the web page, and if you have thousands, it may not load correctly. I will make a change to the form so that this is no longer an issue.


    I do have hundreds of tags (276 in total). Not sure if that was the problem, but that might be the fix. Thanks, Scott.



    I’ve the same edit and delete problem and it is going wrong from the update from WP 3.0 to WP 3.0.1. While I’m using AD Manager 3.4.19.

    When I’m getting the error below, than I know I can’t delete or edit the last two ads anymore and I must go directly into the DB to delete the last two after setting the code-text to something short and simple and change the length of the code-text to the amount of chars directly in database. But after a few minutes the revisions are back??? Sometime this works, but now it doesn’t anymore and I can’t create new ads anymore 🙁

    This is the error I get when I’m creating a new ad when saving withing the second edit screen (after this it is going wrong):
    Message: Object expected
    Line: 63
    Char: 3
    Code: 0
    URI: /wp-content/plugins/advertising-manager/scripts/advman.js?ver=3.0.1

    At line 63 it seems the plugin is saying that I use WordPress 2.6 or lower, but I’m using 3.0.1. I think it has to do with the wordpress new (custom) Post handling or something with quotes.

    When there is a simple solution to delete the revisions of one ad, I’d like to here it!

    Yah I believe it’s a problem with too many tags and it can’t write back to the database, even though initially it says (last edited one minute ago) if you refresh it goes back to >30 days.

    So I tried to find a way to limit the amount of tags it was pulling (I’m not going to be doing any filtering via tags anyway).

    It took me a long time to find where the code was located, I edited the tag queries in Tools.php but it had no effect, I finally found the actual code used was in /advertising-manager/lib/Advman/TemplateMetabox.php

    You need to edit the following lines (#102 & #103):

    $categories = get_categories("hierarchical=0&hide_empty=0&number=10&orderby=count&order=DESC");
    $tags = get_tags("hierarchical=0&hide_empty=0&number=10&orderby=count&order=DESC");

    This will give the 10 most used tags and categories, you can change the number if you like.

    After limiting these queries I can now edit my ads again.

    For reference I have 6052 tags..

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Advertising Manager] unable to add ad after moving to live site’ is closed to new replies.