[Plugin: Advertising Manager] PHP Fatal Error (10 posts)

  1. Vakantie Ameland
    Posted 6 years ago #

    When I create a new ad, import the google code and try to save the ad, this is the log message:

    PHP Fatal error: Call to undefined method stdClass::get_network_property_defaults() in wordpress/wp-content/plugins/advertising-manager/lib/Advman/Admin.php on line 91"

    Nothing is saved, just the wordpress plugin screen with no content in it shows. When I go to the ads, the new ad is not there.

    Can you help me out here.


  2. Vakantie Ameland
    Posted 6 years ago #

    I Just reinstalled the newest version and the problem is gone, for now.... I say for now, because this happened before, 1 in several tries succeeds.

    Somebody any idea what is wrong here.....

  3. Vakantie Ameland
    Posted 6 years ago #

    The plugin is still buggy, had to disable it because of the following error:

    PHP Warning: Invalid argument supplied for foreach() in wordpress/wp-content/plugins/advertising-manager/lib/OX/Ad.php on line 168

    It influences the whole website with blank screens. Could you please fix the bugs..

  4. switzer
    Posted 6 years ago #


    Sorry to hear this. I fix bugs as fast as I can. Can you please let me know the version of WordPress and PHP that you are using? Also, any additional information about how you installed, and what other plugins you are using would be helpful.

    There have been one or two others with this issue, and they reinstalled and the problem went away. I am not saying that this is not an issue - it could be because the advertising manager data was corrupted somehow.


  5. vladbabii
    Posted 6 years ago #

    Quick fix for this error.. it has been driving me nuts for a while


  6. gjperera
    Posted 6 years ago #

    @vladbabii - Thank you so much for the solution to this problem. I updated the code and it worked. Thanks again!

    @Switzer - You might want to include this fix for the next version of Ad Manager. Thanks for the great plugin.

  7. vinko
    Posted 6 years ago #

    Switzer, I have the same problem as christianebuddy, but I was not able to resolve the problem by reinstalling the Plugin.

    I am using WordPress 3.0.1 and Advertising Manager 3.4.19

    Thank you in advance for any advice as to resolving this issue.

  8. jmatthewgore
    Posted 5 years ago #

    I'm getting the same error message. Using WordPress 3.0.1, re-installed latest version of Advertising Manager this morning.

    However, advertising manager was working fine until this morning, and has been working fine for a year or so. This morning, I installed WP-Facebook-Autoconnect, and noticed that my ads were gone afterwards.

    I then removed the new plugin, but AM won't start working again... I just get the error message above if I try to create a new ad... and my widgets only show "defualt" in the drop down boxes.

    The link provided by vladbabii seems to be dead, so if anyone has a copy of that fix and could actually post it here, that would be appreciated.

    - Matthew

  9. deepjm
    Posted 5 years ago #

    have the same problem

    I cant change my ad code
    There is a issue for that?

  10. michaelhart
    Posted 5 years ago #

    Same problem. This addon is beautiful, and would be PERFECT if it just worked.

Topic Closed

This topic has been closed to new replies.

About this Topic