WordPress.org

Forums

[Plugin: Advertising Manager] Banners Sometimes Don't Display (7 posts)

  1. seanwf
    Member
    Posted 6 years ago #

    When using this plugin, it works as intended about 90% of the time. However, upon refreshing or navigating to a different page, sometimes my banner images don't display and default to the "alt" text. I know that there is no problem with the image URL because this problem is not specific to any particular banner.

  2. sperlingreich
    Member
    Posted 6 years ago #

    I am having the same problem. The leaderboard banner is not displaying properly. . . or at all. The header of my site just collapses. Any help would be appreciated.

  3. webmind
    Member
    Posted 5 years ago #

    The biggest problem WordPress is having now is that hundreds of programmers get all excited and create a great plug-in, then get bored and tired with the constant upgrades to the code that are necessary to keep it working. So they go bad and eventually corrupt your website. Pity.

    WordPress should create a special club or group of plugin developers who can retain membership in their plugin club as long as the plugins are updated and working properly with most standard themes. Offer some incentive to make it worth their while, even a $1 a year maintenance fee.

  4. switzer
    Member
    Posted 5 years ago #

    seanwf:
    sperlingreigh:
    webmind:

    I am still around - don't worry! I have been on a holiday for the last two weeks.

    Regarding your issue: what ad are you trying to show? Adsense or some other network?

    It is probable that the ad network that you are displaying just decided not to display an ad for some reason. If you post your URL and the steps that you use to reproduce, I can take a look at it.

    Cheers,
    Scott

  5. DonnaMiller
    Member
    Posted 5 years ago #

    Similar thing is happening on my client's site with the Commission Junction ads. Advertising manager is re-writing the code so it doesn't work. The documentation site is giving a 502 error, so I can't check there to see if there are additional steps we need to take to make it work properly. Can you let me know if anything special needs to be done for CJ ads, or otherwise why this is happening (more importantly how to fix it?).

    Thanks,
    Donna

  6. Walker
    Member
    Posted 5 years ago #

    I have the same problem at chalgabg.com. There is an AdSense ad box at Advertising Manager which should show on all pages (and it did until yesterday), but it doesn't show (and it's not AdSense not showing the ads, because the ad code is NOT even visible on the page source. I have not updated plugins, WP-core files or edited theme files during the period the issue appeared.

    The box is inserted in my template (sidebar) as <?php advman_ad('Sidebar'); ?>

  7. switzer
    Member
    Posted 5 years ago #

    One of the bigger annoyances with serving ads is that it is difficult to figure out why an ad does not show.

    If an ad only sometimes shows (and you have not set any delivery limitations in advertising manager), then it is most likely the 3rd party ad (e.g commission junction, adsense, etc.) which is displaying a blank banner some of the time.

    The way to check this is to 'view source' and see if the ad has been inserted into the page. If it has NOT been inserted into the page, please write back, and I can try to help.

    Cheers,
    Scott

Topic Closed

This topic has been closed to new replies.

About this Topic