Support » Plugin: Advanced Text Widget » [Plugin: Advanced Text Widget] Does not work with shortcode

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Max Chirkov

    (@maxchirkov)

    Shortcodes should work just fine – I just checked on my own site and they do work. Make sure your shortcode is correct (no misspellings) and the plugins that is responsible for it is active.

    Thanks, actually I copied/pasted the shortcode from the settings page for that plugin. I ended up just using an Include to load a page that contained the shortcode instead, and it works fine. It wasn’t working from the widget though for some reason, I just thought you should know.

    Thanks again for getting back to me.

    Plugin Author Max Chirkov

    (@maxchirkov)

    Can you try a shortcode from a different plugin or a core shortcode like [gallery id="xx"] – where xx is the ID of the post to which a gallery attached. I just tried it again on my home dev machine (my previous test was on a live server) and it worked again as well. Therefore I’m not exactly sure where the bottleneck in your case.

    I have some shortcodes from other plugins in use, WP FAQ is working with a shortcode. I also have some other plugins that might be conflicting somehow? I’m using More Fields, Magic Fields, Use Shortcoes in Sidebar Widgets, for instance. I’ve used Ultimate TinyMCE many times with some of these other plugins but never installed add-ons with it. So far, this is the only one causing the issue.

    I’m going to try uploading an editorstyle.css file and see if that changes anything.

    That didn’t work either. And I noticed something else odd, when I’m in the editor in Visual Mode, I highlighted the text to see what was there and I can see HTML in the editor, so that was very strange.

    I don’t know what else to do at this point.

    I made some progress with this (sorry for so many posts!)

    I figured out what was happening with the editor: I had problems with my Arrays – forgot to add the beginning “Array (” since I have more than one, and the ending “)” but now I’m running into another problem, which I will post in a new thread since it’s unrelated to editor issues.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Advanced Text Widget] Does not work with shortcode’ is closed to new replies.