Support » Plugin: Advanced Post List » [Plugin: Advanced Post List] Maximum execution time after update

Viewing 15 replies - 16 through 30 (of 37 total)
  • Plugin Author jokerbr313


    Just giving you another update…

    I’ve redesigned some of the main functions that support the custom post types and taxonomies. Post_Types->Taxonomies->Terms are the main 3, and the ‘get’ functions for them have been slimmed down tremendously to only get what is required for the plugin. It also allows for a lot more adaptability for future upgrades/updates. The other one I still need to code is the functions to get the current post attributes and post type pages (not posts).

    Right now I’m solely working on functions that have relations to /wp-includes/post.php

    Sounds great! Thanks for all your hard work. 🙂

    Plugin Author jokerbr313


    Wow, time really has been flying by. Yet, another update, and sorry about the time that it has taken.

    I have the plugin pretty much updated and finished to release the Beta 4 version, but I’m still a little on edge about it, and I don’t want to release it to the public until I am 100% comfortable with it this time. So, right now I’m working on a bunch of other things that relate to getting a WordPress environment setup. Plus there’s a bunch of other stuff that I’ve been wrapped up in. So there were a few times I had to take a break from the plugin.

    All-in-all, things look good, but I’m still a lil iffy about it fixing your error. What I did was lighten the load on the memory, and try to process the data a little quicker. For example, some functions return values quicker depending on how much processing the function needs to do at the time.

    Pretty much letting you know that I have not forgotten about you. If you want, I can send you a copy of the beta 4 version via email so you can give it a go, but I also prefer not to share my email address on this site. I currently have a free forum that I’m using to swap files and messages, but unfortunately, it requires registration (which we all get tired of going through), and I don’t have a direct link for the download (its still just on my computer). Again though, sorry about the delay.

    The Community Forum

    No worries, I’ll wait until the public release. Fingers crossed it’ll fix the error, unfortunately we won’t be moving to a new server at this time but my host might be able to make some changes if necessary.

    Plugin Author jokerbr313


    Oh ok. I was kinda hoping you’d be the first to try it out and give me feedback on it before I mark it as the next beta release.

    Anyways, I currently working on getting a WordPress site setup and going public with it. I’ve mainly been waiting til I got custom posts and taxonomy support for my plugin before I established a public site again. All the plugins and themes I came across didn’t have the type of post lists support that I was looking for, and Kalin was originally the one to give the plugin a great start and show a lot of potential. So I had to wait. I’m just glad to I decided to author an alt version of the original. It’s been quite the experience =)

    So, it might not be too long til I reply back with a direct link…and I’ll be switching from the current ‘free’ community forum to a WordPress platform with a forum built into it eventually. That mainly has to do with the fact that I need a website that I can also demonstrate this plugin. Along with other reason for centralizing things.

    Glad to hear that your host might be able to help you out. Although, in some cases, he shouldn’t have to. On the other hand, he could have the timeout setting ridiculously low, but idk. This plugin has a lot of power to it, and it could be easy to make it a beast, and I already understand there’s some downsides if you get too carried away with designing basic code to get things started. Which, ultimately, thank you again for bring this to my attention. So far, your the only one to report this though…

    If it’ll help out, I could give it a try. I’ve still got 0.2.0 on hand to go back to, if need be.

    It’s strange, everything’s fine with the tables and the latest version does work on my test dummy site as I said before. Like I said before I can get by with the old version which is working fine, though obviously it’s better to have the latest version with all the updates and features.

    So yeah, if testing it would help out before the public release of Beta 4, I’ll lend a hand. 🙂

    Plugin Author EkoJR


    Sorry about the hold up. I had to take a break and give my brain a rest. After getting some things done to try and fix your issue, I still had more work to do on it before I felt comfortable releasing it. After enjoying some of the nice weather, things have been coming together a lot smoother, and I just released a new version that has multiple bug fixes. I still kind of doubt it will fix your issue, but I tried to lighten the load as much as I can.

    If you can, could you let me know things turn out on 0.3.b4. Thanks in advance.

    Yeah, still no luck unfortunately. Very strange that it works on my test site, hosted on the exact same server, but not the actual site itself.

    I’m actually using Kalin’s Post List now as I don’t need anything more in-depth than that as far as features are concerned, but I appreciate all you’ve done to try and resolve the issue. Best of luck with it moving forward, as I said I think it’s a fantastic plugin. 🙂 Unfortunately it just doesn’t look like the new versions are going to work for me.

    Plugin Author EkoJR


    Something on your site must be making it hang. I just wish I had a way to debug it myself so I can see exactly whats going on and why. Then correct the issue.

    I would recommend using 0.2.0, since it’s the last version without the Custom Taxonomy support. Kalin’s post list had some bugs when it would query posts, and the “Require Categories/Tags’ was one of them. So if your using the require setting, you may want to switch back.

    Everything seems to be working fine with the settings I’m using, but I’ll certainly consider going back to 0.2.0 if I run into any issues.

    Plugin Author EkoJR


    Huh, I don’t remember marking this as resolved. Did you get your issue fixed?!? or just mark it resolved?

    Btw, I still have this issue at the corner of my mind, so you may want to check back every now and then to see if the issue cleared up after a new release version.

    I marked it resolved as I’ve basically found a solution and didn’t want to keep bugging you about this. I’ll definitely keep checking in though.

    Plugin Author EkoJR


    I fixed some issues with script registering which could of prevented clients from receiving data properly from Google’s CDA. Possibly creating a timeout error. Since then I have switch over to WordPress platform’s built in scripts.

    FYI, I have another database upgrade in 0.3.Beta5 (as well as 0.3.Alpha1). So make sure you backup your data first because I currently don’t support downgrading versions (or downgrade update for the database).


    i think i have the same problem. i set up a test site where everything works properly with the same theme, plugins, etc on the same server.

    however when i tried to use it on the real site, it did not work.
    when i click on settings/advanced post list then it says:

    “Fatal error
    : Maximum execution time of 30 seconds exceeded in /wp-includes/post.php on line

    This is a great plugin and would be in a key role in listing posts from some custom post type on my site so i don’t know what to do.

    Any improvement with the issue? I would appreciate any help, thanks in advance.

    Plugin Author EkoJR


    I’m still working on getting this figured out.

    …but I do have a few questions.
    Are you using a Custom Post Type and Taxonomies (CPT) plugin? If so, what is the plugin’s name?
    Have you used multiple CPT plugins on the site in the past?

    Sorry thebeggs4 for this being an ongoing process just to get it figured out.

Viewing 15 replies - 16 through 30 (of 37 total)
  • The topic ‘[Plugin: Advanced Post List] Maximum execution time after update’ is closed to new replies.