WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Advanced Post List] Maximum execution time after update

[Resolved] [Plugin: Advanced Post List] Maximum execution time after update

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author jokerbr313

    @jokerbr313

    Glad you love the plugin. Sorry about the issue though. I hope you backed up your presets prior to upgrading though.

    It could be a number of reasons why your getting that error. The most likely reason is that your getting hung up on something (a loop). It may be a script error, or a script getting an error from some backend code, or maybe something in constructing the settings page. Its hard to tell on my end, but you said this problem only exists on the plugin’s setting page, right?

    Here’s a couple other questions…
    Have you tried disabling other plugins to see if the plugin would work?
    Have you tried selecting “Yes” on “Delete preset upon deactivation” and then deactivating and then reactivating the new plugin version (it should give it a fresh install)?

    Just gave that a try, no luck unfortunately.

    I’ve got a dummy version of my site setup to try out updates and design changes and the latest version is actually working there, it’s just not working on the real site. The only difference is that the real site has more post categories (40 compared to 33), all the other plugins and so on are the same.

    Plugin Author jokerbr313

    @jokerbr313

    Just to give you an update…

    I’ve been looking into the issue trying to figure out what the source could be, and it could also be host related (mainly GoDaddy). I’ve notice a lot of other people recommended modifying the php.ini file’s max_execution_time. I’m also going through the plugin and writing in some safe-guards, but I was wondering, do you know how to turn on Debug in WordPress?

    Sorry I don’t have any more info on this as of yet. Spend most of the day going through the plugin and correcting some things that might be a possible issue. I should have an update available soon though.

    Do you mean via this method outlined in the codex?
    http://codex.wordpress.org/Editing_wp-config.php#Debug

    I should be able to do that, if it would help at all.

    As it happens, we will be moving to a new server soon (we have dedicated hosting) but as I said the new version works fine on our dummy site, which is on the same server, has the same plugins and theme, etc. The only difference is that the real site has a few more post categories and a larger number of posts.

    Appreciate you looking into the matter, 0.2.0 is working fine but it’s obviously better to use the latest version so if we can get it working, that would be great. Please let me know if there’s anything else I can do to assist in the troubleshooting. 🙂

    Plugin Author jokerbr313

    @jokerbr313

    The Debug mode in WordPress might give you an error that I can work with. It isn’t something I recommend using on a public site, but its ultimately up to you if you want to use it. A lot of the times I just create an exact copy of the site’s files and database, and then put it on a localhost (requires some code to be changed in order to make the switch though). After that, I do a step by step debug run with an IDE. The timeout error isn’t much to go by, so a lot of it is guess work, assuming it is related to the plugin.

    I doubt it has something to do with the amount of categories and posts, although I can’t rule it out completely. I used a ton of categories to make up for the loss of the post type & taxonomy support in 0.2, and I didn’t encounter a timeout error while working on 0.3, but not everyone’s problem is the same.

    My main worry however, whether it’s the problem or not, is the plugin’s database. Although, so far, it looks like things are good. My second main worry though is the WordPress scripting support, but the only thing that relies on scripting while loading the page is the preset database table, and nothing needed to be altered in that part of the JavaScript (still the same as you might of noticed)…but the timeout error does have a relation with scripting. Another problem is that you may need to optimize your (phpMyAdmin) database. Since it’s on the same server, its got me wondering if the database might be a lil jumbled up.

    At the moment, I’m working on uploading a new beta version. There were a few things that were throwing ‘strict’ errors that I fixed up. So if you do plan on using debug mode to see if you can catch an error, I strongly advise updating to Beta 3 first, AND using it as brief as possible.

    define('WP_DEBUG', true); Should be the only thing you need to add or change to get it started.

    I would also recommend changing error_reporting() in <em>site name</em>/wp-admin/load-scripts.php, and, optionally, <em>site name</em>/wp-admin/load-styles.php to…
    error_reporting(E_ALL | E_STRICT);, but depending on what other plugins you have, you might catch a lot of other plugin errors.

    Btw, I found some problems with Activate, Deactivate, and Delete/Uninstall action hooks. So after you update to Beta 3, if you could trouble shoot it one more time by restarting it, it should work and give you a clean install to work off of. Sorry, I took a deeper look into it and also found a bug while handling the action hooks.

    Sure thing, I’ll give Beta 3 a shot first when it’s available and take it from there.

    Plugin Author jokerbr313

    @jokerbr313

    Ok, the next beta just got uploaded.

    Just tried it, same problem unfortunately. 🙁

    The “Maximum execution time” error references /wp-includes/post.php, if that helps.

    Plugin Author jokerbr313

    @jokerbr313

    Is that all the error says? and it only happens on the plugin admin page?

    It mentions the full path to post.php in my WordPress installation which I’ve snipped out but that’s basically it: Maximum execution time, exceeded the maximum time of 30 seconds and then the mention of post.php.

    The timeout error occurs when trying to access the settings page for the plugin. Everything else is functioning correctly so far as I can tell.

    Plugin Author jokerbr313

    @jokerbr313

    Well, I’m kind of running out of time to explain it in my next post since i’m about to head out for the evening…but have you made any changes to the php.ini file?

    No, I don’t have access to it.

    Plugin Author jokerbr313

    @jokerbr313

    That’s pretty lame. The hosting that I have you can modify the file.

    Is there any way you could ask the hosting admin to grant you access to modify it? Cause it could troubleshoot your problem. If not, my guess is that they are throttling your site.

    If you do plan on going to a dedicated hosting service. It would probably be a good call to make.

    Plugin Author jokerbr313

    @jokerbr313

    Ok, just another update…since I have another idea that I was planning on doing in the next subversion anyways. I took a closer look at wp-includes/posp.php and I noticed that I use some of the functions within the file. Which I didn’t think would have ‘post-type’ functions.

    What I’m going to do is slim down the functions to use only what is necessary instead of using the whole object (which mainly means using WordPress functions that don’t return objects, I was using get_post_type_object($args) for instance), and also separate some code into different functions. I had most of the varibles in the plugin slimmed down, but something in post.php is hanging.

    After this, I’m out of ideas til I can think of something else. I think its server based. After you told me where it was coming from I started thinking it could be a function in the file, looking at it now, it very well could be the case. I was already planning on slimming down functions and variables, so I’ll give it a shot.

    We are currently on dedicated hosting, our host will just be moving us to a better server in the future. I might be able to get access to it or be able to get him to make some changes if need be but it might be better to wait since the move will be happening soon.

    Those changes sound good though, I’ll give that version a try when it’s available. Appreciate all the help so far. 🙂

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Resolved] [Plugin: Advanced Post List] Maximum execution time after update’ is closed to new replies.