Support » Plugin: Advanced iFrame » [Plugin: Advanced iframe] Hide Elements Doesn't work

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author mdempfle

    (@mdempfle)

    Have you read the documentation and are you able to provide more details?

    Do you maybe have any Javascript errors on your page. Because then this cannot work anymore.

    Yes I’ve read the docs over and over. As I understand it it’s supposed to hide #id and .class elements from the iframed page. I have tried to hide headers and nav elements and only display the main content sections of pages but to no avail. No java errors that I can see. I want to just iframe the maps in this page and hide the header.

    http://www.torontorealestateboard.com/buying/district_map/index.htm

    Plugin Author mdempfle

    (@mdempfle)

    You can only hide elements from the page you include the iframe in!
    Not from the page in the iframe!

    I wrote this because wordpress often e.g. displays a e.g. header, right navigation you can now turn off to give the iframe more space.

    – Michael

    Thanks for the clarification. My theme allows me to use full width pages etc.

    Plugin Author mdempfle

    (@mdempfle)

    Then you only need this plugin if you like to forward parameters to your iframe.

    – Michael

    So there’s no way to display just part of a page within the iframe? I would really like to hide the header or footer of the page within the iframe!

    Plugin Author mdempfle

    (@mdempfle)

    no. You would have e.g. to pass a parameter which is read by the page in the iframe and hides the header/footer

    I’m not sure how to hide elements in my iframe… i’ve read all the documentation.

    this is my shortcode
    [advanced_iframe securitykey="22222222222222222222" src="http://www.abc.net.au/perth/news/" width="555" height="555" scrolling="no" marginwidth="" marginheight="" id="" name="" frameborder="" content_id="" content_styles="" hide_elements="#header" class="" url_forward_parameter=""]

    but it doesn’t hide the header?

    thanks
    Pete

    Plugin Author mdempfle

    (@mdempfle)

    does the header has the id “header”?
    A link to your page would help here ;).

    Best, Michael

    yes it does

    yes it does

    Plugin Author mdempfle

    (@mdempfle)

    have you tried to configure it in the administration and not as short code?

    Plugin Author mdempfle

    (@mdempfle)

    Can you provide an url? I just tested the hide feature and it works fin if configured right.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Advanced iframe] Hide Elements Doesn't work’ is closed to new replies.