Support » Plugins » Hacks » [Plugin: Advanced Excerpt] "Read More" text not added to custom excerpts

  • Resolved lwimble


    (Plugin v4.1.1) I noted that the plugin would not add the “Read more” text to custom excerpts, which resulted in now way to get to the full post. I modified the plugin by replacing line 121

    return $text;

    return($this->text_add_more($text, $ellipsis, ($add_link) ? $read_more : false));

Viewing 5 replies - 1 through 5 (of 5 total)
  • I will consider implementing this, but it might bother people who want to include a link manually in their custom excerpts. Either way I never win. 😛

    Thanks for your response!

    Perhaps this could be an option? In my case, I have numerous people who can post, some with wordpress experience, and some with none. Those with experience will use custom excerpts. On our front page, only excerpts are shown. The problem I experienced was that some excerpts had “Read more” links and others did not.

    I solved my problem by doing a little hacking, but it would be really nice if this were an option.

    In any case, thanks for your plugin!

    Kind Regards,
    Larry Wimble

    I agree with @Iwimble.

    I’m trying to use your plugin b/c i’m having a problem overriding the continue reading in my child theme of twenty eleven.

    If I have to change the plugin to make this work, it kinda defeats the used of the child theme. This is because i would still be changing the source of something that could change on update.

    Other then that, the plugin is great.

    I’ve been considering this for a little bit and I think it would make more sense to always automatically add the link if the option is activated. It seems more consistent with the purpose of excerpts in general (even if it is a custom one).

    Even though this plugin is all about customisation I am hesitant to add an option for every permutation. I prefer choosing a default that makes sense and see how people respond to it, then change it or make it optional depending on what happens. 🙂

    That said, I will use your suggestions for the next update. Thanks for your feedback!

    I had the same problem. I solved it by unchecking the Read More button in the Advanced Excerpt panel, and inserting read more links with a custom function. See section headed “How to add a link beneath an excerpt to the full post”. That adds read more links to every time the_excerpt is called.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Advanced Excerpt] "Read More" text not added to custom excerpts’ is closed to new replies.