Support » Plugin: Advanced Excerpt » [Plugin: Advanced Excerpt] New v4.0 Causes "wordpress cannot modify header information" er

  • Resolved microberto

    (@microberto)


    Just upgraded to 4.0, and every time I post something, this plugin gives the error: “wordpress cannot modify header information”

    The file automatically retrieved from the upgrade server had spaces before the <?php tag, and also didn’t have ?> at the end.

    Please fix that in a minor release so that nobody else gets the error.

    http://wordpress.org/extend/plugins/advanced-excerpt/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same here. Causes the error in other pages too.

    For those of you seeing this, just edit the advanced experpt php file and remove the spaces from before the <?php

    Not sure if you need to, but add a new line at the end and type in ?> with nothing after it.

    Good enough for me now, but I won’t be upgrading this on my other sites.

    The space at the beginning is indeed the problem. I don’t know how I missed that.

    You can fix it yourself using Plugins -> Editor to remove the spaces in front of <?php. It is not necessary to put ?> at the end of the file, though.

    I updated the download now. So upgrading or downloading the plugin again should also work.

    I updated the download now. So upgrading or downloading the plugin again should also work.

    So… 4.0 is now fixed?

    Can’t say that I’m a fan of a “hidden” release. That is a bit unethical and you should have made it 4.0.1 for the people who already upgraded to 4.0 and aren’t aware of these threads (on top of just being ethical and admitting your mistake via version control).

    Anyway, I’ll delete it and reinstall on this site to confirm.

    I agree the hidden update wasn’t the best way, but the change is minimal and I did it very shortly after the initial release.

    4.1 should be out very soon, though and this time it will be tested properly. Sorry for the inconvenience.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Advanced Excerpt] New v4.0 Causes "wordpress cannot modify header information" er’ is closed to new replies.