Support » Plugin: Advanced Excerpt » [Plugin: Advanced Excerpt] Excerpts not working 4.4.1

Viewing 8 replies - 1 through 8 (of 8 total)
  • Update: After a bit of experimentation, I’ve found that it puts the “read more” text after the first image, regardless of where that image appears in the excerpt.

    And a final update: it works correctly if “Don’t remove any markup” is checked, so this provides a possible work-round

    I was having the same problem. The “… [read more]” was showing up in the middle of some excerpts, not the end.

    I discovered after much trial and error that if, in the Advanced Excerpt Options section, I went to the Keep Markup section and UNchecked the boxes for the following two html tags

    [em]
    and
    [strong]

    …the plugin placed the “… [read more]” at the end of the excerpt.

    Unfortunately, I was hoping to keep the em and strong tags, which was part of the point of using a plugin (to keep the styling), but something’s better than nothing!

    I was getting the read more link placed in the middle of the excerpt, right after the second link in it. I had to exclude link tags to fix it, ending up with this:

    <?php the_advanced_excerpt('length=50&add_link=1&use_words=1&no_custom=1&ellipsis=%26hellip;&exclude_tags=div,img,p,strong,a');?>

    Again, lost functionality, but works.

    I’m having the same issue running 3.3.2 and the latest version of the plugin. Dylan, thanks for the work around. It would be nice if this great plugin worked as intended.

    I was having the same problem, to solve I had to comment out the following code from the following 4 lines of code in the function called: text_add_more
    // $pos = strrpos($text, ‘</’);
    // if ($pos !== false)
    // Inside last HTML tag
    // $text = substr_replace($text, $ellipsis, $pos, 0);
    // else
    // After the content
    $text .= $ellipsis;

    I can’t see any purpose to these lines of code, and my excerpts all seem to be working correctly now.

    Please could this code be fixed permanently on the next update of this superb plugin?

    Thanks

    Mmm indeed the previous post was most effective but there is a purpose to those lines. It now always add the read more comment on a new line rather that it appends.

    I’m running the ArjunaX theme with the latest version of wordpress. I had previously set my reading settings to show only excerpts. When landing on a results page after a search, the reader is not able to click on the three dots to read more. They have to click on the title. I’ve set the read settings to show the entire post but the three dots still appear and are not clickable. Please help! The site is http://www.europeanbiotechnologist.com. Searching for a word like “pcr” will give you a good idea of what I’m talking about.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Advanced Excerpt] Excerpts not working 4.4.1’ is closed to new replies.