WordPress.org

Support

Support » Plugins and Hacks » Advanced Custom Fields » [Resolved] [Plugin: Advanced Custom Fields] The New Gallery Field does not Work

[Resolved] [Plugin: Advanced Custom Fields] The New Gallery Field does not Work

  • [ Moderator note: please use backticks or the code button for snippets like that. ]

    I’ve installed the new Gallery Field coming with ACF 3.2.9 and it doesn’t work.

    First in the edit page, it prints out php code below the gallery field:

    'attachment', 'numberposts' => -1, 'post_status' => null, 'post__in' => $value, )); $value = array(); foreach( $attachments as $attachment) { // create array to hold value data $value[] = array( 'id' => $attachment->ID, 'alt' => get_post_meta($attachment->ID, '_wp_attachment_image_alt', true), 'title' => $attachment->post_title, 'caption' => $attachment->post_excerpt, 'description' => $attachment->post_content, ); } /* // format attachments $ordered_attachments = array(); foreach( $attachments as $attachment ) { $ordered_attachments[ $attachment->ID ] = $attachment; } // update value with corisponding attachments foreach( $value as $k => $v) { // get the attachment onject for this value (attachment id) $attachment = $ordered_attachments[ $v ]; // create array to hold value data $value[ $k ] = array( 'id' => $attachment->ID, 'alt' => get_post_meta($attachment->ID, '_wp_attachment_image_alt', true), 'title' => $attachment->post_title, 'caption' => $attachment->post_excerpt, 'description' => $attachment->post_content, ); } */ // return value return $value;	 } /*-------------------------------------------------------------------------------------- * *	get_value_for_api *	- called from your template file when using the API functions (get_field, etc). *	This function is useful if your field needs to format the returned value * *	@params *	- $post_id (int) - the post ID which your value is attached to *	- $field (array) - the field object. * * @author Elliot Condon *	@since 3.0.0 * *-------------------------------------------------------------------------------------*/ function get_value_for_api($post_id, $field) { // get value $value = $this->get_value($post_id, $field); // find all image sizes $image_sizes = get_intermediate_image_sizes(); if( $value ) { foreach( $value as $k => $v ) { // full url $value[$k]['url'] = wp_get_attachment_url( $v['id'] ); // sizes if( $image_sizes ) { $value[$k]['sizes'] = array(); foreach( $image_sizes as $image_size ) { // find src $src = wp_get_attachment_image_src( $v['id'], $image_size ); // add src $value[$k]['sizes'][$image_size] = $src[0]; } // foreach( $image_sizes as $image_size ) } // if( $image_sizes )	 } // foreach( $value as $k => $v ) } // if( $value ) // return value return $value; } /* * popup_head * * @description: * @since 3.2.8 * @created: 6/07/12 */ function popup_head() { // $_GET is required if( ! isset($_GET) ) { return; } // options $defaults = array( 'acf_type' => '', 'acf_gallery_id' => '', 'preview_size' => 'thumbnail', 'tab'	=>	'type',	 ); $options = array_merge($defaults, $_GET); // validate if( $options['acf_type'] != 'gallery' ) { return; } ?>

    Second when i click “Add images”, a php warning comes in the head of the media-upload window with this message :

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'acf_Gallery' does not have a method 'popup_head'

    I guess a closing php tag is missing in the code… i’ll check.

    http://wordpress.org/extend/plugins/advanced-custom-fields/

Viewing 3 replies - 1 through 3 (of 3 total)
  • I found the bug Elliot !

    Line 289 in the gallery.php file, the opening php tag was just “<?”, replaced it with “<?php” and everything is working nice !

    Nice add-on !

    Plugin Author elliotcondon

    @elliotcondon

    Thanks jlambe,

    Can’t believe I had a php short tag in there!
    Sorry about that, all fixed now and I’ve updated the core.

    Cheers
    Elliot

    It was a pleasure 😉
    Cheers !

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: Advanced Custom Fields] The New Gallery Field does not Work’ is closed to new replies.
Skip to toolbar