WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Advanced Custom Fields] Fatal error: Cannot redeclare class

[Resolved] [Plugin: Advanced Custom Fields] Fatal error: Cannot redeclare class

Viewing 7 replies - 1 through 7 (of 7 total)
  • Until the developer fixes this, you can modify the file and wrap the class in a class_exists() condition. e.g.,

    if( !class_exists( 'acf_walker_taxonomy_field_checklist' ) )
    {
        class act_walker_taxonomy_field_checklist()
        {
            // ....
        }
    }
    Plugin Author elliotcondon

    @elliotcondon

    Hi guys,

    This looks like an error with the advanced-custom-fields-taxonomy-field-add-on plugin. I would advise leaving a support question on his / hers plugin page

    Thanks

    Seems the developer tried fixing it using the wrapper:

    if( !class_exists( 'ACF_Walker_Taxonomy_Field_Checklist' ) ) :
    ....
    endif;

    But this still causes an error sometimes. But when I changed to the following, error doesn’t occur:

    if( !class_exists( 'acf_walker_taxonomy_field_checklist' ) ) {
    ...
    }

    I tried changing if/endif to traditional {}, but I still receive the error on an irregular basis. Come on, ACF! Fix your plugin already!

    @elliotcondon: This error has been reported via github and they’re pointing us back to you.

    I confirm @deeve007 fix works well.

    Plugin Author elliotcondon

    @elliotcondon

    Hi @naillik

    Can you post a link to the thread where they link this back to me?
    I don’t see how this is an issue with ACF, the issue is with the taxonomy field add-on created by another developer.

    P.S. v4.0.0 has it’s own taxonomy field built in!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Advanced Custom Fields] Fatal error: Cannot redeclare class’ is closed to new replies.