WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Advanced Custom Fields] Edit post interface not working after upgrade

[Resolved] [Plugin: Advanced Custom Fields] Edit post interface not working after upgrade

  • I love the Advanced Custom Fields plugin, but with the latest update to the version 3.0.0, something seems to go wrong.

    When I am on the edit post interface, several (standard) links and buttons aren’t working anymore. I cannot edit the post slug (getting the editPermalink is not defined javascript error,) set the post publication date, add post tags, upload images, etc.

    I know that this error is related to upgrading Advanced Custom Fields to 3.0.0 because it didn’t appear just before the upgrade, but also because temporarily disabling only this plugin restores the functionality of the edit post interface back to normal.

    I’m also sure it’s not a browser-related issue because I tried 2 different web browsers and I just kept getting the same error. I’m even having this unresponsive buttons and links problem in 2 different installations of WordPress.

    I have a custom text and textarea fields included in all the edit post pages whose links and buttons aren’t working.

    I tried the usual hacks to restore the javascript functions of the interface with no luck (disabling CONCATENATE_SCRIPTS in wp-config, re-uploading wp-includes and wp-admin, etc.) But the only solution to remove this conflict seems to disable the Advanced Custom Fields plugin. Any ideas?

    http://wordpress.org/extend/plugins/advanced-custom-fields/

Viewing 15 replies - 1 through 15 (of 20 total)
  • I’m exactly on the same situation! Several functions on posts and pages were killed. Could you please fix it immediately?

    I temporarily downgraded to 2.1.4.

    Hey Friends,

    If you go into the actual custom field that you created, there is a menu at the button full of checkboxes to turn on and off those settings. Perhaps when you upgraded, those preferences got wiped. Check this out:

    http://screencast.com/t/tYSvQhfRX5r5

    Hope this helps!

    Thank you for the suggestion, Jackie, but I have already checked that. And I’m 100% positive that I have the features I want enabled on those checkboxes. I even tried to unmark the checkboxes and then enable them again, with no luck. On top of that, I actually see the links and buttons I want to click – it’s just that they aren’t responding. So the problem isn’t there.

    I’d say that there’s some kind of conflict between Advanced Custom Fields and the Javsacript of WordPress, making several elements (visible buttons and links) in the edit post interface not work at all.

    The only workaround I found so far is to disable the plugin of Advanced Custom Fields and then performing those tasks that were failing before that (like editing the slug, inserting images, editing the publishing date, setting the featured image, etc.) And then, re-enabling the plugin again (fortunately, the configuration data of the Advanced Custom Fields aren’t lost in this process.)

    But of course, this procedure causes some downtime of the features depending on Advanced Custom Fields, and I really fail to find where the conflict between the plugin and the WordPress buttons and links is.

    I am having the same issue.

    Exactly the same thing for me as well. Going to try and roll back.

    Same here, trying to roll back

    THIS IS CRITICAL FOR US, we can’t update posts, even when I roll back to 2.1.3 and the custom fields are an integral part of a website we rolled out this week! Need a solution.

    Just checked the Advanced Custom Fields version 3.0.1 in WordPress 3.2.1 and the conflicts between the links of the edit post / edit page with ACF persist. Most links and buttons remain unresponsive. I verified this keeps happening on the latest versions of Firefox and Chrome.

    @eserrano
    Same here, last update didn’t resolve the error. I verified it with Safari and Chrome.

    I really hope this get resolved. This plug-in is such a time saver. When working correctly I would happily pay for this plug-in.

    Same issue here on a few sites. Has anyone discovered a work-around for this?

    Exactly the same here, although I don’t have the problem on a fresh wp install with no other plugins activated.

    I’ve been adding other plugins one by one, the problem occurs when I activate Headspace2 as well as advanced custom fields…

    So do you think it is caused by a plugin interaction?

    I don’t have Headspace2 installed. So if this is a plugin interaction between Advanced Custom Fields and other plugins, it is not limited to Headspace2.

    Headspace2 adds some additional fields to the edit post interface, doesn’t it? Maybe plugins adding more fields to the edit post interface should be the suspects of such malfunction.

    Okay, I’m not sure about why some plugins might be conflicting with Advanced Custom Fields 3.0.0 or 3.0.1 on WordPress 3.2.1 but, my problems seemed to be completely fixed when updating to Advanced Custom Fields 3.0.2. I guess that version fixes the issues.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] [Plugin: Advanced Custom Fields] Edit post interface not working after upgrade’ is closed to new replies.