WordPress.org

Forums

Advanced Custom Fields
[resolved] Broken images buttons above WYSIWYG editor (4 posts)

  1. Jacob Dunn
    Member
    Posted 3 years ago #

    The image buttons for insert images/video/audo/media were broken once we moved our site onto Rackspace's cloud servers. I was able to track down the issue - the images linked to
    sitename.com/wp-admin//images/media-button-other.gif?ver=20100531

    (Note the double / after admin)

    I've located the relevant code in {plugin-dir}/core/fields/wysiwyg.php lines 267-276.

    All that has to be changed is all occurrences of
    src="<?php echo $this->parent->wpadminurl ?>/images
    to
    src="<?php echo $this->parent->wpadminurl ?>images

    Enjoy!

    http://wordpress.org/extend/plugins/advanced-custom-fields/

  2. elliotcondon
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks mate, I'll add this in the next update

  3. simco
    Member
    Posted 3 years ago #

    I have this same problem but the latest version of the plugin doesn't have lines 267-276. That file now stops at 226. And I hoped when I saw this post title that I'd found the Holy Grail! I need this fixed, the media button no workie!

    Any updates on this bug fix?

  4. elliotcondon
    Member
    Plugin Author

    Posted 3 years ago #

    Hi simco

    I believe Jacob Dunn was talking about a very old version of ACF which created the WYSIWYG button HTML itsel.

    Now, ACF uses the do_action( 'media_buttons' ) to create the buttons. The HTML should be the same as WP

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Advanced Custom Fields
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic