Support » Plugin: Advanced AJAX Page Loader » [Plugin: Advanced AJAX Page Loader] Could not bind to search form…

  • Resolved chameleontunes

    (@chameleontunes)


    So I am trying to use this awesome plugin but for some reason I keep getting the following error
    : Could not bind to search form…
    could not find element with id=’searchform’ or attribute ‘action’ missing.

    I followed all of your steps in the FAQ, but that didn’t fix anything. I am not good with code or anything like that. Was wondering if you could help me out. I think someone else had the same problem a week ago. Help us noobs out because I want to use this badass plugin on my site as soon as possible!

    http://wordpress.org/extend/plugins/advanced-ajax-page-loader/

Viewing 15 replies - 1 through 15 (of 15 total)
  • I’m getting the same error. I’m using WordPress 3.4.1.

    Same problem here.

    larssonk22

    (@larssonk22)

    Manishkrag couldn’t get yours working

    I noticed something on my blog, when I view a post it doesn’t show the sidebar which I am using for my navigation. So when I added

    <?php get_sidebar(); ?>

    before the call for footer my sidebar appears and no more errors

    manishkrag

    (@manishkrag)

    Hi lassonk, can I get your site link so I can see what exactly the issue there.

    larssonk22

    (@larssonk22)

    Hi Manishkrag, I’m not using your plugin but here is the site

    http://streetfighteraf.com

    News section is the blog page

    manishkrag

    (@manishkrag)

    Hi,

    Thanks for the link,

    You can try this plugin in your dev version,
    – Activate AWS plugin.
    – Go to AWS plugin settings page
    – In 2nd field provide primary
    – In 3rd field provide menu-main-menu-container
    – Check the site
    – Hope this will work.

    Plugin Author Dean Williams

    (@deano1987)

    this is not a major problem, when in debug you will get all debug messages and this one simply warns you that AAPL could not locate the “search box” on your blog so that it could bind searches to work with AJAX.

    To fix it, if you have a search form, just add ” id=’searchform’ ” to the <input> element of your search box.

    Disable the “debug mode” to stop these warnings and information popups.

    manishkrag: I don’t think asking people to use your plugin is a great idea, it’s a nice plugin but far less feature rich and browser compatible as this one.
    If your going to post – you should be HELPING – not trying to get exposure for your own plugins.

    larssonk22

    (@larssonk22)

    Dean, you wouldn’t happen to know how to get the plugin to work correctly on iphones or mobile devices would you?? If I view my site on an iphone the menu fills the whole screen covering the page content.

    Plugin Author Dean Williams

    (@deano1987)

    the menu ills the screen? Sounds more like an issue with your css/html than the AAPL plugin, does this go away when you disable AAPL?

    cepxuo

    (@cepxuo)

    Dean,
    Here is the piece of code for my serach form:

    <form role="search" method="get" id="searchform" action="http://rueda.uz/" >
    	<div><label class="screen-reader-text" for="s">Find:</label>
    	<input type="text" value="" name="s" id="s" />
    	<input type="submit" id="searchsubmit" value="Search" />
    	</div>
    	</form>

    The form has ID=”searchform”, the same ID is set in options of AAPL, but still when I press the search button the page is reloaded completely, not using your plugin. How can I make your plugin work?

    PS: debug mode says that plugin cannot find the form with ID=”searchform”. But as you see it is there.

    PPS: I just checked and found out that search with previous version AAPL (2.6.0) works fine, but with new version (2.6.1) does not work.

    larssonk22

    (@larssonk22)

    Hi Dean, thanks for the response. You are right looks like the twenty eleven theme has viewport script I wasn’t aware about. Since removing the script the site works as intended.

    Plugin Author Dean Williams

    (@deano1987)

    cepxuo : there was a slight bug in 2.6.0 I should have not been binding using ID anymore and should be using class – as this will mean more than one search field can now be used on the page.

    So instead of id=”” you should now set class=”” with the class name you have in the AAPL options.

    Sorry for the confusion.

    cepxuo

    (@cepxuo)

    Thanks a lot, Dean! Now it works perfectly!

    Plugin Author Dean Williams

    (@deano1987)

    great 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Advanced AJAX Page Loader] Could not bind to search form…’ is closed to new replies.