Support » Plugins » [Plugin: Advanced Ajax Page Loader] could not bind searchform

  • I’m experiencing some trouble with this plugin. At first it didn’t work, as I clicked to view older posts on the frontpage the link in the adressbar changes, but the page just moves up and that’s it.( (like a refresh)

    Then I tried to execute the “Theme support instructions”. Unfortunately I’m using a kind of complex theme (Salutation) and I don’t have the files that are referred to. For example index.php give the following:

     * NOTE: this file is for compatibility.
     * Layouts are created in the theme options and "design-{name}.php" files.
     * Content is generated by the "template-{context}.php" files.

    Then I searched through the files for the div tag that contains: ” if (have_posts()) : while (have_posts()) : the_post(); “
    I found this in the file “template-page.php”
    I edited it to:

    if (have_posts()) :
    	while (have_posts()) : the_post();
    	<div class="content-page">
    	<div id="content-sal123"

    (I assume this is correct, I’m definitely not an expert)

    But it’s was still not working. I set showWarning to true in ajax-page-loader.js file
    Then as I refreshed my homepage I got the following error:
    “Could not bind to searchform……..
    Could not find element with id=’searchform’ or atribute ‘action’ missing.”

    It has probably something to do with the second part of the Theme support instructions, however the theme I’m using doesn’t use search.php nor does it use searchform.php. I only have template-search.php, but that file doesn’t contain the div, form and input elements that are referred to.

    Anyone got an idea?

Viewing 2 replies - 1 through 2 (of 2 total)
  • I’ve contacted the developer of the theme. He suggested the I’m probably looking for template-blog.php and search-template.php

    He also said that the theme support instructions were very specific and that not many themes have these specific files/code. Can anyone help me to get this plugin running with this theme? Does anyone know which code I have to change in the files above to get it running? Or are the above files irrelevant and do I need to make the changes in other files? Please help 🙂


    I need help with this problem too. I get the problem when viewing posts on my blog, I’m using wordpress’s 2011 theme. Not sure if it’s relevant but the post won’t load any embedded image till you click ok.

    EDIT: Fixed

    I noticed when I view posts my blog doesn’t show the sidebar which I am using for my navigation. So when I added

    <?php get_sidebar(); ?>

    before the call for footer, now my sidebar appears and there is no errors

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Advanced Ajax Page Loader] could not bind searchform’ is closed to new replies.