WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Advanced AJAX Page Loader] '#' anchor links are not working

[Plugin: Advanced AJAX Page Loader] '#' anchor links are not working

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Dean Williams

    @deano1987

    The plugin is setup to ignore all # links by default, because using # i na link is to define an anchor and not to define a new web page.

    For SEO purposes I would seriously consider changing your URL scheme so that it avoids # in links to define new pages.

    However you can change the behaviour of AAPL so that it AJAX’s links with the # in the url by removing # from the ignore list which is on the settings page.

    # anchor is very useful to go to certain are of webpage, which is used with plenty comment plugins to go directly to needed comment. that’s why it appears to be so important..

    Dean, is there any chance to check the adress and ignore the link to the same page displayed, or do the job if not? Well actually it would be great if just the page rolls to the anchor, like it is done by default..

    Plugin Author Dean Williams

    @deano1987

    Dan I think you misunderstand, this is why AAPL ignores # links because they are used for anchors within the page.

    I thought you meant that you are using # links to go to new pages, this is the only reason you would want AAPL to be able to pick up the clicks.

    So the default behaviour should be correct in your case – now I’m confused.

    I’m sorry for my English, but what I mean is that going to “..page2.html#comments” from page1.html will load page2.html and then scroll you to “comments” anchor there, wich is very convenient (for viewing exact comment and so on). So it is another page but with scrolling to needed area..

    Is it possible to do?

    Plugin Author Dean Williams

    @deano1987

    Right now I understand,
    yes I shall look to implement this

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Advanced AJAX Page Loader] '#' anchor links are not working’ is closed to new replies.