Support » Plugin: Advanced AJAX Page Loader » [Plugin: Advanced AJAX Page Loader] Ajax just loads forver,

  • Resolved slgoetz


    I have used this loader before and it worked great, but for some reason on my current site it is just staying on the loader for an infinite amount of time, It says the error is Uncaught TypeError: Cannot call method 'indexOf' of undefined I have literally tried everything I can think of, including changing my .htcaccess and making all the folders publicly accessible. does any one have any idea of what I can do to fix this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Dean Williams


    could you click on the error message and post the line of code it has halted on please? I’m assuming your using FireFox or Chrome.

    Uncaught TypeError: Cannot call Method ‘indexOf’ of undefined and the line that is being called out is

    data = data.substring(data.indexOf('>') + 1);

    line 190 on ajax-page-loader.js

    Plugin Author Dean Williams


    goto the AAPL admin panel and turn on debugging – do you get any popups when you load the site?

    all i get is

    Could not bind to search form…
    Could not find element with id=’searchform’ or attribute ‘action’ missing.

    i got the same errors on another domain when the ajax’d plugin worked.
    -i dont have search enabled.

    Plugin Author Dean Williams


    Yup that one can be ignored.

    Hmm perhaps you could point me to a URL of the plugin activated so I can check it out?

    I figured out the issue, apparently you can not minify the code, thanks again for trying to help, your plu-in is great, you can check out the website

    Plugin Author Dean Williams


    Oh yes, no you cant – it changes the variable names which causes it to detach from the initialization (reading the settings).

    Sorry to re-open this, but I’m facing the same issue. I’m facing the same issue as slgoetz, but I don’t have any minification going on. I have a fairly vanilla install going on at my staging site.

    With the default options, it works fine; however, if I set the output to be something other than “container” (e.g. the empty div “output” it’s currently set at), it gives me the same loading problem as above, and the same JS error.

    Appreciate any help at all. Thanks!

    Ok i figured the issue out on my end …

    Turns out whatever ID you tell AAPL to load the content into, also needs to be the ID of the div of content from the page you are trying to load …

    I was trying to load into an empty div … and the page being loaded didnt have the appropriate ID in the content.

    Also be sure to check that “the_content()” function is called inside that div as well.

    Great plugin … my recommendation would be ::

    – Adding support to define certain elements or menus to load pages

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Advanced AJAX Page Loader] Ajax just loads forver,’ is closed to new replies.