Support » Plugin: Advanced Access Manager » [Plugin: Advanced Access Manager] Metaboxes and Widgets not listing after initialisation

Viewing 13 replies - 1 through 13 (of 13 total)
  • Even with SOAP enabled, the list of Metaboxes and Widgets is still not listed. I even tired with other posts, and yet nothing. This is getting really frustrating.

    Plugin Author Vasyl Martyniuk


    Hi eljkmw,
    SOAP has nothing to do with AAM functionality. There are only two specific cases when it is used.
    If you have Firebug, check how AJAX calls are doing. What errors are triggered? Also if you have an access to your server error log, please check it too.


    My server’s error log is empty.
    Besides, I’m unfamiliar with Firebug on how to check the AJAX calls.

    Please advise. Thank you.

    Hi Vasyl,

    I’ve used Firebug – Net – XHR to check for Ajax requests.
    It resulted in:

    POST admin-ajax.php 200 OK 20 B
    POST admin-ajax.php 200 OK 2.5 KB

    List of Metaboxes is still empty and cannot be initialised.
    What else could be the problem?

    Thanks in advance,

    Plugin Author Vasyl Martyniuk


    Hi Jason,
    Is there any possibility to give me an admin access to your website?
    I’d like to check it.


    Hi Vasyl,

    You can try setting up WP 3.4 with it and will get the result that eljkmw is talking about. I’m having the same issue on two different installs of WP 3.4. (I haven’t tried it on 3.3 branch yet). I get nothing from the server log or from Firebug.

    Simply put, nothing is being returned and no errors are showing up.

    Edit: Forgot to add that manual initialization didn’t work either.

    Hi Vasyl,

    I was doing some random tests today to see if I could come up with why 3.4 and 3.3.2 of WP won’t return the metaboxes. Yeah even on 3.3.2. Vanilla installs and nothing else. No server log or Firebug errors and even WP_Debug returns nothing.

    As luck would have it – I installed WP 3.2.1 and AAM 1.4.1 as control (as these two versions work well together and with my workflow). I initialized the metaboxes etc and then did an upgrade to both WP and AAM to the latest versions. Now the metaboxes work (ok SOAP error on the about page not installed – but no biggy AAM still works).

    The problem seems to be with the very first initialization of the metaboxes. So basically when installed on WP 3.4 not upgraded, AAM 1.6.7 first initialization won’t work period. If a previous version is installed and initialized the upgrade goes smoothly and everything seems to work (I double checked).

    Hope this helps.

    Hi Vasyl.

    I’m afraid I’ve removed your plugin as I’ve decided not to apply it to my website. Moreover, I’m using an older WordPress version on my website, which I feel that your plugin might be operate in. I’ll probably wait until your plugin is stabilised in WordPress 3.4, and preferably without the need of using SOAP.



    Hi again,

    I think this particular problem amongst others from different AAM versions at least from 1.4.1 and onwards is related to how the host server is setup.

    So far I’ve been doing random testing for the past week now and I’ve come close to some decent results.

    By the way regarding SOAP – if it’s not installed you will get an error for the about page. If you are on shared hosting just ask the host to install it should not be a problem.

    If you are on a managed server double check to ensure the cURL module is installed. Do phpinfo(); test and check if it is available. This is one thing you’d think managed hosting would have set it up for you but seems like some don’t and you’ll have to or your server admin will have to install it for you.

    On shared hosting I’m still getting varying results so I’m trying to narrow it down. I will let you know as I progress.


    PS: Vasyl if you have any input regarding what modules AAM uses for php it would be great because it doesn’t seem like all shared/managed hosts have everything setup as one would think either.

    Plugin Author Vasyl Martyniuk


    Hi guys,
    Currently I’m trying to reproduce the fault and no luck. But I’m going to perform few more test.
    george.n uses cURL (for multisite setup), SOAP (for AWM Group About page and Premium Upgrade). Rest I’m trying to keep compatible within standard PHP features.


    Ok so… talk about getting myself into a mess lol.

    I went ahead and ensured all extensions needed on a typical php setup are working for the Zend Framework and phpQuery on shared and managed hosting.

    For the most part the problem is resolved but out of countless activations and initializations it seems to work and maybe fail once or twice. So it may be a random issue on shared hosts (managed hosts works so far).

    However, to my rotten luck, the initialization does not work on my local development server at all. I don’t know if I did something wrong or I have successfully replicated the bug – (permanently? 🙂 ). This happened after I made sure that all typical php extensions are installed and working on this server.

    Everything else does work in AAM just not the initialization. One thing I can tell you Vasyl, is that Json returns status “success” for every post type. I double checked to ensure that it’s not returning “success” with no reason by installing bbPress. Json now returned “success” for bbPress post types also… just not showing anything.

    So if it wasn’t something I did wrong then it must be happening with phpQuery or at least ajax that it’s not returning the results.

    I hope this helps in any way. (Btw, every test I made so far is on a fresh install of WP).

    I believe this issue “may” be because of qTranslate (or in light of it). I’m still doing some debugging to verify it.

    Hi, I´m working with 3.4.2 WP Multisite version, when i click in settings Metaboxes & Widgets Tab, button Initialize the list. The progressbar show and complete the proccess but the metaboxes & widgets list don’t show.

    I have not found the solution for this problem. I work with multisite page and the plugin only work in one site of my sites.

    Does anyone have this problem?. I have more plugins running with Ajax & JSON.

    Sorry for my poor English, I´m spanish.
    Thanks for this great plugin, helps me a lot.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Advanced Access Manager] Metaboxes and Widgets not listing after initialisation’ is closed to new replies.