Support » Plugins » [Plugin: Advanced Access Manager] Cannot retrieve menu items in dashboard

  • After installing Advanced Access Manager, most of my menu items in my dashboard disappeared – logged in as admin, I can only see menus added by other plugins: “Products” (from my wp-ecommerce), “Contact” (from Contact Form 7), “Coming Soon” (from a plugin) and the “AWM Group” menu. Everything else is gone (Users, Settings, Pages, Posts, etc) – and I can’t figure out how to add them back. I still have access to them, because I can pull them up in my browser history, but the links are all gone and not available in the Main Menu tab to include/exclude.

    How do I add back the menu items that have disappeared?

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hi SherrisOffice,
    Sounds like u lost admin rights.
    What version of AAM and WP u used?


    Thanks for the quick reply!
    I am using WP 3.3.1 and AAM 1.1.6.

    I guess AAM 1.6.1.
    Try to restore your admin rights. Read


    Sorry – version

    I tried that, and still do not see the proper menus on my dashboard.

    I DO still have access to them, I just don’t see the menus on the sidebar to click on to get to them.. it’s like someone excluded them from my view, and now they are missing from the Main Menu section of AAM, so I can’t uncheck/include them.

    For example, I can view/edit/delete a list of my plugins if I type “” into my browser, I just don’t have a menu/link called ‘Plugins’ on the left side of my dashboard. This makes me think that I still do have admin rights but lost visibility of the actual menus..?

    How can something be added back to the Main Menu section of AAM?

    Thanks for all your help and for a great plugin!!

    Oh. Try to click restore default button (yellow arrow) for admin role (or any other role your user has).
    For more info about it read this:
    Let me know the result.


    Tried that – still no change. Here is a screen shot of all I can see:

    I have now updated AAM to version 1.6.2 – is there some way I can add back the menu items that are missing? Thanks for all your help!

    Hi SherrisOffice,
    I believe there is other plugin which deals with menu list too. And this cause a conflict.
    Is it possible you deactivate one by one your plugins and check which one, possible, cause that.


    I deactivated all plugins and my menus came back, and disappeared again when I reactivated “WP e-Commerce User Roles and Purchase History” – looks like AAM and that add-on to WP e-Commerce don’t play well together.

    Thanks so so so much for your help and your AWESOME plugin – I am using it for all of my (30+) client sites.

    Thanks for info. I’ll check this add-on and let u know how this can be fixed (if fix is applicable).


    Hi Vasyl,

    I got almost same problem… I use AAM Version 1.6.2, after I activate AAM plugin( I didn’t do any setting in AAM), then the admin menu changed, lost something like edit and add new post.
    I tried and, nothing changed. I checked the error log, it’s empty. And I deactivate all the plugin, still same… What can I do?

    Hi timyao1977,
    Do you still have an access to menus that are no longer shown in menu?
    Like Edit or Add New Post.


    Hi Vasyl Martyniuk,
    Yes, I still can edit post through the front end post edit button but I can’t add new post( it shows “You do not have sufficient permissions to access this page”).

    Others I lost are some custom post types menu.

    If I create a new administrator user, then it will have a full menu except AAM(the AAM sub menu lost, and if I click AAM Group menu, will shows “Error during template parsing. Please follow the link to read more”).

    OK. In such way just click restore default button for admin role (orange arrow). Also if you want to give access to other admins to AAM you have to read FAQ how to do that.


    Hi Vasyl Martyniuk´╝î
    I’ve tried to restore before, it’s no use. And now I tried again, still same.How do you think?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: Advanced Access Manager] Cannot retrieve menu items in dashboard’ is closed to new replies.