WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Advanced Access Manager] Admin privileges lost!

[Resolved] [Plugin: Advanced Access Manager] Admin privileges lost!

  • All access to admin functions of my client’s site are gone! Can’t change a thing anymore …

    I’ve read others had the problem before. I just didn’t see it coming – because there was no javascript warning.

    Started the plugin, clicked OK on the popup and waited. Nothing happend, the loading wheel kept spinning. Eventually I tried and hit the X. The window closed. No error message. I figured everything is fine.

    Then I made changes to some roles. Not to admin rights, though. But as I hit the SAVE button I saw that – while I thought I had switched roles all the while using the buttons on the bottom of the main frame – my active role had actually remained Admin. So all changes where saved for Admin. And all my admins. No Superadmin got created.

    Please help!

    D

    http://wordpress.org/extend/plugins/advanced-access-manager/

Viewing 15 replies - 1 through 15 (of 27 total)
  • Alright, worst case avoided. Somehow I could restore my rights using the browser back-arrow …

    Still that superuser doesn’t seem to get created. I’m now keeping that popup window open … has been open for more than ten minutes now … won’t go, won’t change a thing.

    But still no JS-Warning or anything.

    Using plugin version 1.5.5
    and WordPress 3.3.1

    Plugin Author Vasyltech

    @vasyl_m

    Hi dostojewski,
    If you are using Firefox and you have firebug it’ll be really helpful for me if you check what error appears in ajax request.
    Eventually you can send me a login (whimba (at) gmail.com) to your dashboard and I’ll check myself.
    I’ll check this issue tonight and will try to prepare solution for next release.

    Regards,
    Vasyl

    Apparently it’s a file missing I haven’t heard of:

    “NetworkError: 500 Internal Server Error – /wp-admin/admin-ajax.php”

    Plugin Author Vasyltech

    @vasyl_m

    🙂 So where is your admin-ajax.php ?
    I’m just curious how your WordPress installation works without it.

    Check if you configured correctly .htaccess and if this file really exists, because this is WordPress core file

    Well, I checked – and it’s right there where it should be.

    So a thing about access rights? Everything else in the backend works fine, though, and I don’t want to grant too many group privileges.

    Plugin Author Vasyltech

    @vasyl_m

    Compare ajax request URL for example when u create new tag and ajax request URL in Access Manager page. Are they equal?

    I have the same problem! All my permissions are broken! Please, could you re-post the link for the repair.php file?? How can i fix my admin role? Thank youu….

    Plugin Author Vasyltech

    @vasyl_m

    Hi,
    Please read – http://whimba.org/forum/viewtopic.php?f=7&t=6

    Regards,
    Vasyl

    it doesn’t work…

    i want to cry… i havent a backup…;(

    Plugin Author Vasyltech

    @vasyl_m

    Espirdeurope, there is no reason to cry. Do you have access to your database? If yes, then I you can manually restore permissions.

    Yes! I send it to you

    Do I have to write it here or you can tell me what to do?

    Plugin Author Vasyltech

    @vasyl_m

    ofcourse not here. This is public area, you don’t want to give access to evetybody to your installation. Send it to me on email whimba (at) gmail.com and I’ll check it.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] [Plugin: Advanced Access Manager] Admin privileges lost!’ is closed to new replies.