Support » Fixing WordPress » [Plugin: AdSense Manager] Plugin broke when I upgraded to 2.5

  • I’m runing the latest version of the plugin and recently updated to wordpress 2.5 and my ads no longer show up.

    Everything looks fine except in the Design >> widget page where I see the following error:

    Warning: Missing argument 2 for adsensem::widget() in D:\Inetpub\wwwroot\website\wp-content\plugins\adsense-manager\adsense-manager.php on line 186

    Fatal error: Call to a member function show_ad_here() on a non-object in D:\Inetpub\wwwroot\website\wp-content\plugins\adsense-manager\adsense-manager.php on line 196

Viewing 7 replies - 1 through 7 (of 7 total)
  • I don’t get the error/warning you cite, but my ads don’t appear any more either after upgrading to v2.5. Nothing on the author’s page so far, either.

    I have th opposite problem I get the broken design >> widget page but my ads are currently showing after upgrading to v2.5.

    Thanks for the heads up, I was away and missed the release of WP2.5. I’m downloading now and will release a bug fix asap.

    Thanks again for the feedback.

    Ok, I’ve submitted a ‘fix’ as 3.2.1 but I’m not sure it’s going to solve all the problems. Upgrading to the latest version works fine here but there is some weirdness (i.e. the Ads are listed in the widgets by their name only, rather than with ‘Ad #name’ as it *should* be) that suggests there have been bigger changes somewhere.

    I’ll look into it over the next few days and see if I can find out what’s going on. Let me know if the latest version works for you.

    Thanks again.

    Running 2.5 .. initial setup .. on go to the widget’s page .. at the bottom on the page ..

    Fatal error: Call to a member function on a non-object in /home/.bellow/mtpc/stevebuchan.org/aeon/wp-content/plugins/adsense-manager/adsense-manager.php on line 196

    thoughts?

    /s

    Can you download 3.2.10? It should fix this bug for you. Thanks for reporting it… it’s caused by leftovers from upgrading/importing: the cause should now be fixed, but it left some weirdness in the db.

    Let me know how you get on.

    I had the same problem and fixed it by going to Manage>>AdUnits and then going to edit network then filling in my account number in the blank box (if you go to adsense page, you will see it in top right, called publisher id) Once I’d saved the changes, problem was solved.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: AdSense Manager] Plugin broke when I upgraded to 2.5’ is closed to new replies.