WordPress.org

Forums

AdRotate
target URL doubling domain, returning 404 error (2 posts)

  1. immanence
    Member
    Posted 2 years ago #

    Strange behaviour started today.

    The following is code I'm using in one ad (I have many ads, all are working okay):

    <a href="http:/mysite.com/section/egypt/?tag=morsi"><img src="%image%" /></a>

    I replaced the ad image today, and amending the reference URL, but only slightly, just changing the tag and section, and nothing else.

    Now, when I update the ad and look at it live, I see the following URL, which fails, leading to a 404 error:

    http:/www.mysite.com/mysite.com/section/egypt/?tag=morsi

    So, for some reason, the URL is duplicating. I'm not sure why. If I set the URL in my code to the following it works:

    <a href="/section/egypt/?tag=morsi">

    But I really need it to work, and to understand why with a perfectly okay URL it is not working.

    Does AdRotate need www. before the domain?

    Is there another reason for the error?

    http://wordpress.org/extend/plugins/adrotate/

  2. Arnan de Gans
    Member
    Posted 2 years ago #

    AdRotate does not require www. OR http://. If http:// is missing AdRotate will add it for you.

    I checked the code there is no way the url shows up twice. Besides. If it did, www. would show double as well. Which it doesn't.

    Can you post a full screenshot of the settings for your ad here?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • AdRotate
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags