Support » Plugins and Hacks » [Plugin: AdRotate] Error locating database tables

[Plugin: AdRotate] Error locating database tables

  • Ed


    De-activated the 2.x plugin, uploaded 3.x files, re-activated plugin, getting the following error:

    There was an error locating the database tables for AdRotate.

    under “Manage Ads”, “Manage Groups”, and “Manage Blocks”. “User Stats”, “Admin Stats” and “Settings” all work.

    Even manually deleted all the database entries for the plugin and re-activated it, still have same issue.

Viewing 15 replies - 1 through 15 (of 15 total)
  • This will be addressed in 3.0.1



    Problem still exists in 3.0.1

    I checked the database, it’s not creating tables on activation.

    This became a problem for me when I updated to 3.0.2



    Yup, same problem in 3.0.2

    Checked the database, still not creating tables on activation or re-activation.

    Sorted and tested in 3.0.3 (for real this time!)

    I just updated 3.0.3 but I get the same error message.

    Ah, sorry, I did the deactivation and reactivation and seems to be working now.



    That fixed it! Thanks so much for your efforts.

    Yes, thank you. The quick response is appreciated.

    I ended up writing a new installer similar to what WordPress uses for its upgrades. This seems to work very well, i’ve had no reports of it not working yet.

    I’m getting this “Error locating database tables”, even after installing/activating the plugin on 3.0.3.

    Any solution to fix this? I’m dying to try out this plugin. Thanks!

    When I activate the plugin the following message comes.
    “The plugin generated 220 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.”
    or on other site
    “… 215 characters …”
    and on pluginsite
    “There was an error locating the database tables for AdRotate. Please deactivate and re-activate AdRotate from the plugin page!!
    If this does not solve the issue please seek support at http://www.adrotateplugin.com/page/support.php
    Nothing changes if I deactivate and re-activate.

    Check your wp-config.php file and make sure that you have the correct value for DB_CHARSET. Older versions of WordPress used ‘utf-8’, but it should actually be ‘utf8’ on newer versions of MySQL. The database install portion of this plugin attempts to use the DB_CHARSET when creating the tables, so if it is invalid, tables won’t get created.

    I overcame this issue with the following steps:

    1. Update DB_CHARSET value in wp-config.php
    2. Deactivate and delete the AdRotate plugin
    3. Manually remove the wp_options record for ‘adrotate_db_version’ (the uninstall fails to do this).
    4. Re-install AdRotate

    @ Brownoxford: Odd but true 🙁 I’ve updated the KB for it. Thanks for the heads up!

    I have used the charset trick. 😉
    And it runs. 🙂

    Yes the problem is the different charset versions of wordpress using in the past. I have wordpress installations that uses iso-8859-1 and utf-8 is the past.

    So I have cleaned up my database to utf8, use utf8 in wp-config, delete adrotate_db_version and adrotate_config from wp_options table in db. Then I have upgrade from adrotate 2.6.1 to 3.0.3 without deleting adrotate tables in db or uninstall plugin.
    Upgrade works fine! And all ads are available. No data lost.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: AdRotate] Error locating database tables’ is closed to new replies.