Support » Plugin: Adminimize » [Plugin: Adminimize] problem with the latest version, after upgrade (1h ago)

  • Resolved Ovidiu

    (@ovidiu)


    when it comes to hiding menus, I only see this: Can't load menu and submenu where I would formerly see the menus.

    I will revert back to the last version as that one worked for me.

    error log doesn’t give me anything useful except maybe this:

    [Wed Mar 02 23:56:48 2011] [warn] [client 87.178.241.177] mod_fcgid: stderr: PHP Deprecated:  Function eregi() is deprecated in /var/www/clients/clientxx/webxx/web/wp-content/plugins/wp-phpmyadmin/wp-phpmyadmin.php on line 46, referer: http://www.jadeyoga.co.za/wp-admin/options-general.php?page=adminimize/adminimize.php

    http://wordpress.org/extend/plugins/adminimize/

Viewing 15 replies - 16 through 30 (of 54 total)
  • @frank: sent

    @frank the latest version you sent me (1.7.14) works! The “Can’t load menu and submenu” error is fixed. Thank you very much!!

    Same problems here ;(

    Tried adminimize1.7.13a.zip – didn’t fix it.

    downgrading to 7.12 didn’t work, had to restore database also

    I’m using 3.1 multisite

    Plugin Author Frank Bueltge

    (@bueltge)

    please now use 1.7.14 and give me an feedback; i have add an fallback for reload menu-data

    on a dev site the options were blown out.

    when to the live site and exported the settings, re-imported to dev site and they were there.

    clicked on update settings with no real updates done and didn’t get the error this time.

    Thanx Frank! Version 1.7.14 works on my projects!

    sorry for not following hte discussion too closely but I just tested the latest version: 1.7.14 and it works perfectly again.

    may I ask what the issue was, roughly, no details needed.

    I am still having problems
    I have wordpress 3.1
    adminimize 1.7.14
    Capability Manager 1.3.2
    When I hide an admin panel for a custom role created in Capability Manager it does not affect a user of that role. Nothing is hidden.
    I am guessing that this is because Adminimize is not compatible with custom roles created in Capability Manager. I am going to test this out with the default roles in wordpress to see if Adminimize works with them.

    I have tested this with custom roles created in Capability Manager 1.3.2 and this is what was causing my problems. I have reverted back to default roles and this has now fixed the issues i mentioned above.

    sorry I’ve tested a further after creating the custom roles after I have installed adminimized 1.7.14 and it does indeed work with capability manager 1.3.2.
    It must have been messed up because the origional custom roles were created before I installed this new version.

    I’ve figured out what was going on.
    I created new roles in capability manager by copying the default roles in wordpress. This was to simplify the names of roles for my users.
    To test adminimize I created a duplicate editor role using capability manager, calling it testeditor
    I now have two editor equivalent roles each with the same capabilities and levels 7, called Editor and testeditor.
    I created two users one for each role editor and test editor.
    I then deactiveated the same menus for both, this hid the menus for both.
    I then deleted the editor user and then deleted the editor role.
    Adminimize stops working for the testeditor roles user.
    If I recreate an Editor role and update the options in adminimize the hidden menus are hidden again for the testeditor role.

    It appears that without existing wordpress default roles adminimize stops working.

    Plugin Author Frank Bueltge

    (@bueltge)

    MAybe you can use this plugin http://wordpress.org/extend/plugins/members/ for create custom roles and change/addd objects on default roles and give me also an feedback.
    I have noc changed since verison 1.7.8 on the roles functions, only 1.7.14 has now a fallback for the users, she have problems to load menu data

    @funkimunk:
    this one is my favorite: http://wordpress.org/extend/plugins/user-role-editor/ might help you too.

    Tevya

    (@thefiddler)

    Frank, since I’m assuming you’re subscribed to this thread, I just wanted to see if you were aware a lot of people are having issues with the latest versions (.13 & .14) of the plugin not working with WP 3.1?

    For me, it seems to work well for one or two user roles, but not for all. Some seem to completely ignore all settings, while at least one obeys almost all (not sure on one or two what they are).

    See these threads for more info:
    http://wordpress.org/support/topic/plugin-adminimize-not-working-at-all-for-me?replies=2
    http://wordpress.org/support/topic/plugin-adminimize-1714-not-working-in-305-or-31-for-admin-role-only?replies=6
    http://wordpress.org/support/topic/plugin-adminimize-1714-doesn-not-work-on-wp-31?replies=10
    http://wordpress.org/support/topic/plugin-adminimize-1715-not-working-in-wp-31?replies=2

    Plugin Author Frank Bueltge

    (@bueltge)

    Hello,
    yes, i work on a new version and will see for the problems. But current i have so much work, with more priority 🙁
    On all my tests works fine with the default roles, not with custom roles and i will see for changes on WP 3.1 to this part.
    Also current i have fixed the WP Nav Menu keys and more.

    different fixes are in the trunk (http://downloads.wordpress.org/plugin/adminimize.zip), your are can tests – please and give me feedback! Thanks.

Viewing 15 replies - 16 through 30 (of 54 total)
  • The topic ‘[Plugin: Adminimize] problem with the latest version, after upgrade (1h ago)’ is closed to new replies.