Support » Plugin: Adminimize » [Plugin: Adminimize] Hide page and subpages (edit.php)

  • Resolved jokerot

    (@jokerot)


    I need to hide edit.php and edit.php***…

    i hide edit.php page and i worked, but when i click on any other link e.g.
    drafts ( edit.php?post_status=draft&post_type=post )
    all (…)
    etc…
    it show the hidden stuff again.
    now i need all that hidden.

    i searched a bit and found this
    $def_post_pages = array( ‘edit.php’, ‘post.php’, ‘post-new.php’ );
    in adminimize.php
    and when i try to add ‘edit.php?post_status=publish&post_type=post’
    inside it wont work but when remove any of those inside it seem to be the right place to add the string .
    Is it something with the strings or…
    Any help will be appreciated.

    http://wordpress.org/extend/plugins/adminimize/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello everyone!

    I want to disable some backend menus for the administrator (and leave them available only for a super-admin role).

    Ok, so i checked the Users (users.php) and Add New User (user-new.php) and now i wanted to uncheck them and make them available again for the administrator. This doesn’t work anymore! I can’t uncheck them at all. I tried with all the other menus and everything works except for these two items – very strange! So i tried to check (disable) them for the “Editors” and then when i tried to uncheck the boxes again – surprise – it won’t work. So once checked, those boxes keep their status forever and ever.

    Any suggestions? Any trick to uncheck them directly from the database?

    Thanks!

    Plugin Author Frank Bueltge

    (@bueltge)

    you can always remove the settings, the last box in settings page of Adminimize reset to default.
    Maybe i will check this, i dont see an problem in my tests.

    Plugin Author Frank Bueltge

    (@bueltge)

    qjokerot: now i have fixed, next release works it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Adminimize] Hide page and subpages (edit.php)’ is closed to new replies.