Support » Plugin: Adminimize » [Plugin: Adminimize] Disable Publish Feature is Not Working

  • Resolved katelynanton


    I’m setting up two different user accounts for my WordPress site. There is Administrator (me) and Authors. While using Adminimize to limite the available privilages for my Authors, I’ve found that the ability to disable publishing for them does not work.

    In the settings menu for the plugin, there is a menu called ‘Write Options’-‘Post’. Underneath that, there is a checkbox for ‘Publish Actions’. I click the button and save, and when I log back into my test Author account, I can still publish a post.

    What can I do to solve this issue?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Frank Bueltge


    This options remove only the area across the publish button.
    If you will hide the button, than remove the capabilities, is more secure; maybe with the plugin Members, change the role and remove this object on the role.
    Alternative add an custom option in Adminimize for the ID: #major-publishing-actions

    Dear Frank,

    I also can’t make Adminimize work.

    I clicked checkbox of Adminimize to deactivate the button of “Post”, “Comment”, “Contact form”, “Profile” and “tool” of contributor on Menu Options. ( I want to activate only “custom post type”.) However, these button remain activate at contributor side…

    What can I do to solve this issue?

    WordPress ver. 3.4.1
    Adminimize ver. 1.8.0

    I have same issue and cannot resolve it.
    if a member is an “Author” then It doesnt disable the “publish” button.

    If I change the user role to “Contributor” then the publish button is “submit for review”.. which is exactly what I require (ie they cannot publish). HOWEVER .. the media functions (upload image) are disabled in contributor EVEN THOUGH THEY ARE UNCHECKED.

    The complete ideal solution I need is contributors can upload images but NOT publish the posts.

    many thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Adminimize] Disable Publish Feature is Not Working’ is closed to new replies.