WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Adminimize] 1.7.14 not working in 3.0.5 or 3.1 for Admin role only

[Resolved] [Plugin: Adminimize] 1.7.14 not working in 3.0.5 or 3.1 for Admin role only

  • We are having trouble on a couple different blogs using 1.7.14 on WordPress 3.0.5 and 3.1. The issue is similar to others mentioned here in the forums where no matter the options that are set, they are not being hidden for the Admin role. They are, however, working for all other roles (Editor, Author, and Subscriber). The interesting thing is that the Adminimize Javascript and CSS files are not being loaded at all for the Admin user.

    We are not running these as a multi-site setup so there is no Super Admin, but we’ve found something interesting.

    In looking through the plugin’s code, we commented out Line 194 through 198 as well as line 678 through 682. These code blocks start with a comment “exclude super admin”. By commenting this out, Adminimize starts to work for the Admin roll in all areas of the admin panels besides the menus and submenus.

    It appears that by excluding the Super Admin, it is also excluding the standard Admin roll as well.

    I hope this helps others. We’re been scratching our head for about 48 hours.

Viewing 7 replies - 1 through 7 (of 7 total)
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Adminimize] 1.7.14 not working in 3.0.5 or 3.1 for Admin role only’ is closed to new replies.