Support » Plugins and Hacks » Admin SSL » [Plugin: Admin SSL] function "user_can" breaks everything

  • After upgrading to wp 3.1, this plugin breaks the whole site because it defines a function “user_can” which WP 3.1 also defines.

    I replaced “user_can(” with “admin_ssl_user_can” throughout the plugin, then a find/replace on “current_admin_ssl_user_can” with “current_user_can” throughout the plugin to resolve.

    Here’s the 1.4.1b version that you can manually install until the plugin author fixes it: http://ge.tt/6HRidQv/admin-ssl-secure-admin.1.4.1b.zip?type=download

    NOTE: if you’re not good with wordpress and manually moving file around, you should probably just wait for the update to come out.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Run these sed commands within the admin-ssl-secure-admin directory.

    sed -i '/user_can/ s/user_can/admin_ssl_user_can/g' *php
    sed -i '/current_admin_ssl_user_can/ s/current_admin_ssl_user_can/current_user_can/g' *php
    Plugin Author blenjee

    (@blenjee)


    Please try version 2.0-b2, I have it running on my own site and it works fine, I’ll release it as version 2.0 if no-one else reports any issues.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Admin SSL] function "user_can" breaks everything’ is closed to new replies.